Closed Bug 1392446 Opened 5 years ago Closed 5 years ago

Stylo: Rules Inspector Empty

Categories

(DevTools :: Inspector: Rules, defect)

56 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1390455

People

(Reporter: shobson, Unassigned)

References

Details

Attachments

(1 file)

The rules inspector periodically goes empty.

Things that do not fix it:
- trying to inspect a different element
- switching to the Layout Inspector and back
- closing dev tools and re opening them
- opening the same webpage in a new tab and and trying to inspect it there

Browser console output:

<unavailable>  protocol.js:938
Protocol error (unknownError): couldn't find start of the rule  utils.js:207
Protocol error (unknownError): couldn't find start of the rule  rules.js:821
<unavailable>  protocol.js:938
Protocol error (unknownError): couldn't find start of the rule  utils.js:207
Protocol error (unknownError): couldn't find start of the rule  rules.js:821
<unavailable>  protocol.js:938
Protocol error (unknownError): couldn't find start of the rule  utils.js:207
Protocol error (unknownError): couldn't find start of the rule  rules.js:821
PS, I am on 57.0a1
Does the issue go away if you disable Stylo in about:config (layout.css.servo.enabled to false)?
Flags: needinfo?(shobson)
I had been working on the page for some time before the problem started the first time.

I disabled Stylo, opened and closed the dev tools, and it did not go away. But then I closed the dev tools and refreshed the page and re-opened dev tools and it was fixed. 

This was happening to me last week too, not sure when Stylo was switched on.
The is currently an active experiment for Stylo in Nightly, with 80% on / 20% off, so that might be why you've seen different things over time.

You do need to reload the page to apply the pref change, so what you described sounds like a Stylo issue.

Can you share the CSS file for those elements?  I'd like to figure out of it's related to bug 1390455, which is about non-ASCII characters in the CSS file.
Summary: Rules Inspector Empty → Stylo: Rules Inspector Empty
I think it was this page: https://developer.mozilla.org/pt-BR/docs/Glossario/Grid_Areas$edit

You will have to create an account to see the page if you don't have one already.
Flags: needinfo?(shobson)
Thanks for the report Stephanie!

Does the markup/dom view go empty at all or is it just the rule view?
I think duplicate of bug 1390455
Just the rule view (see screen shot with comment 0)

Happened again here: https://developer.mozilla.org/en-US/ You don't need to login for that one ;)

First time it has happened to me immediately upon opening the tools in a new tab on a new page.
Okay, I just tried out https://developer.mozilla.org/en-US/ and I can verify the issue.  It seems like it's related to Font Awesome, which uses non-ASCII rules like:

.icon-music:before {
 content:""
}

So, seems like it is indeed the same as bug 1390455.  Thanks for filing, we'll track it over there!
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1390455
Ah, just thought I should add that using the Style Editor to remove all these non-ASCII things makes the rule view work again, so that's why I feel confident it's the same.
Duplicate of this bug: 1393463
Blocks: 1382285
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.