Intermittent dom/media/test/test_seek_nosrc.html | Test timed out.

REOPENED
Assigned to

Status

()

P5
normal
REOPENED
a year ago
10 days ago

People

(Reporter: intermittent-bug-filer, Assigned: jhlin)

Tracking

(Blocks: 1 bug, {intermittent-failure, leave-open})

unspecified
intermittent-failure, leave-open
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 wontfix, firefox58 affected, firefox59 affected)

Details

Attachments

(2 attachments)

Updated

a year ago
Flags: needinfo?(alwu)
Created attachment 8900062 [details]
Error log

From the log, I saw the binder died so we got the decoded error.

> E/GeckoRemoteManager( 8708): remote codec is dead

Hi, John,
Is it possibly a OOP issue?
Flags: needinfo?(alwu) → needinfo?(jolin)
(Assignee)

Comment 2

a year ago
(In reply to Alastor Wu [:alwu][please needinfo me][GMT+8] from comment #1)
> Created attachment 8900062 [details]
> Error log
> 
> From the log, I saw the binder died so we got the decoded error.
> 
> > E/GeckoRemoteManager( 8708): remote codec is dead
> 
> Hi, John,
> Is it possibly a OOP issue?

 Yes, the remote decoder process is dead during sending input buffer. The error/exception handling code should be changed to return non fatal error (rather than OOM error) for reader to retry.
Flags: needinfo?(jolin)
(Assignee)

Updated

a year ago
Assignee: nobody → jolin
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
(Assignee)

Comment 8

a year ago
Looks like a problem in media shutdown process:

11-20 15:30:25.872 I/Gecko   ( 6404): FATAL ERROR: AsyncShutdown timeout in profile-before-change Conditions: [{"name":"MediaShutdownManager: shutdown","state":"(none)","filename":"/builds/worker/workspace/build/src/dom/media/MediaShutdownManager.cpp","lineNumber":83,"stack":"MediaShutdownManager shutdown"}] At least one completion condition failed to complete within a reasonable amount of time. Causing a crash to ensure that we do not leave the user with an unresponsive process draining resources.
(Assignee)

Updated

a year ago
Duplicate of this bug: 1393866
(Assignee)

Updated

a year ago
Duplicate of this bug: 1346631
(Assignee)

Updated

a year ago
Duplicate of this bug: 1414850
Comment hidden (mozreview-request)

Comment 13

a year ago
mozreview-review
Comment on attachment 8933580 [details]
Bug 1392747 - add debug message to trace media shutdown process.

https://reviewboard.mozilla.org/r/204518/#review210092
Attachment #8933580 - Flags: review?(jwwang) → review+
Comment hidden (Intermittent Failures Robot)

Comment 15

a year ago
Pushed by jolin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6524c2d721db
add debug message to trace media shutdown process. r=jwwang
(Assignee)

Updated

a year ago
Duplicate of this bug: 1394848

Comment 17

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6524c2d721db
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox59: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Looks like this wasn't meant to be resolved yet.
Status: RESOLVED → REOPENED
status-firefox59: fixed → ---
Resolution: FIXED → ---
Target Milestone: Firefox 59 → ---
(Assignee)

Comment 19

a year ago
Thanks a lot, Ryan.

Added leave-open keyword until the root cause is found and fixed.
Keywords: leave-open
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Jon, I see lots of these "DEBUG SHUTDOWN" log messages when running Nightly from the macOS command line and loading http://www.syfy.com/theexpanse/enterthefuture/inside. Do we still need these log messages?

[DEBUG SHUTDOWN] ShutdownDecoder: decoder: 'apple coremedia decoder' (0x16a864820) flush:1
[DEBUG SHUTDOWN] Shutdown: reader=0x16b259000 shutdown demuxer=0x16b240710
[DEBUG SHUTDOWN] Shutdown: pool=0x1423fad90 count=2
[DEBUG SHUTDOWN] ShutdownDecoder: decoder: 'apple coremedia decoder' (0x16b1561e0) flush:1
[DEBUG SHUTDOWN] Shutdown: reader=0x16b350000 shutdown demuxer=0x164014e20
[DEBUG SHUTDOWN] Shutdown: pool=0x142305cd0 count=2
[DEBUG SHUTDOWN] operator(): pool=0x1423fad90 shutdown=true count=1
[DEBUG SHUTDOWN] operator(): pool=0x142305cd0 shutdown=true count=1
[DEBUG SHUTDOWN] operator(): pool=0x1423fad90 shutdown=true count=0
[DEBUG SHUTDOWN] TearDownDecoders: reader=0x16b259000 shut down audio task queue
[DEBUG SHUTDOWN] TearDownDecoders: reader=0x16b259000 shut down video task queue
...
status-firefox57: --- → wontfix
status-firefox58: --- → affected
status-firefox59: --- → affected
Flags: needinfo?(jlin)
(Assignee)

Comment 25

a year ago
(In reply to Chris Peterson [:cpeterson] from comment #24)
> Jon, I see lots of these "DEBUG SHUTDOWN" log messages when running Nightly
> from the macOS command line and loading
> http://www.syfy.com/theexpanse/enterthefuture/inside. Do we still need these
> log messages?
> 
> [DEBUG SHUTDOWN] ShutdownDecoder: decoder: 'apple coremedia decoder'
> (0x16a864820) flush:1
> [DEBUG SHUTDOWN] Shutdown: reader=0x16b259000 shutdown demuxer=0x16b240710
> [DEBUG SHUTDOWN] Shutdown: pool=0x1423fad90 count=2
> [DEBUG SHUTDOWN] ShutdownDecoder: decoder: 'apple coremedia decoder'
> (0x16b1561e0) flush:1
> [DEBUG SHUTDOWN] Shutdown: reader=0x16b350000 shutdown demuxer=0x164014e20
> [DEBUG SHUTDOWN] Shutdown: pool=0x142305cd0 count=2
> [DEBUG SHUTDOWN] operator(): pool=0x1423fad90 shutdown=true count=1
> [DEBUG SHUTDOWN] operator(): pool=0x142305cd0 shutdown=true count=1
> [DEBUG SHUTDOWN] operator(): pool=0x1423fad90 shutdown=true count=0
> [DEBUG SHUTDOWN] TearDownDecoders: reader=0x16b259000 shut down audio task
> queue
> [DEBUG SHUTDOWN] TearDownDecoders: reader=0x16b259000 shut down video task
> queue
> ...

 Yes, the debug messages were added to diagnose intermittent shutdown time-outs on Android and are still needed. If you find it annoying, perhaps we could make it Fennec only?
Flags: needinfo?(jlin)
(In reply to John Lin [:jolin][:jhlin] from comment #25)
>  Yes, the debug messages were added to diagnose intermittent shutdown
> time-outs on Android and are still needed. If you find it annoying, perhaps
> we could make it Fennec only?

They're not so bad. :) I don't think we need to change them. Few people Firefox Nightly from the command line and that website just happened to instantiate a lot of video decoders. For comparison, YouTube only instantiates one per page.
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)

Comment 29

11 months ago
Pushed by cpearce@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f5e1970ca337
Backed out changeset 6524c2d721db. r=backout
I backed out the logging, as it's annoying on non-Android, and no-one is looking at the failure. We can re-land the logging (Android only please) when someone has cycles to look at this again.
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.