Closed Bug 1392959 Opened 2 years ago Closed 2 years ago

New about:accounts action needed, "email"

Categories

(Firefox :: Sync, enhancement, P3)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 57
Tracking Status
firefox57 --- verified
firefox58 --- verified

People

(Reporter: stomlinson, Assigned: gasolin)

References

()

Details

(Whiteboard: [fxa][photon-onboarding])

Attachments

(1 file)

The new onboarding tour for Photon has (or at least had, today's doesn't seem to have it) a "Sync" section [1] that allows users to enter their email address. When the user enters their email address and submits the form, about:accounts?action=signup is opened with the email address. It would be nice if we could instead send the user to about:accounts?action=email where action=email opens FxA's `/` route with the `?action=email&email=<email>` query parameters. From there, we'll determine whether the email is registered or not and direct the user down the correct flow.


[1] - https://bugzilla.mozilla.org/show_bug.cgi?id=1357023
See Also: → 1357023
Whiteboard: [fxa]
Alex, are you able to take this on?
Flags: needinfo?(adavis)
I've reached out to the onboarding team on Slack to bring this bug to their attention. 
I'll leave the ni? on me until they answer.
Rex is this something we can do? Sounds straightforward.
Flags: needinfo?(rexboy)
The action to be taken is hard-coded in UITour.jsm, not in Onboarding module. It's possible to change it but would need some effort.
Given we are working on new proposal and some urgent bug fixing ongoing, I think we may prioritize it lower; but we can discuss it in triage.

Just a confirm, there are no works from fxa server side right?
Flags: needinfo?(rexboy)
Whiteboard: [fxa] → [fxa][photon-onboarding][triage]
Priority: -- → P3
Whiteboard: [fxa][photon-onboarding][triage] → [fxa][photon-onboarding]
Since we already send additional `email` option to UITour to visit about:accounts page with email address, we can alter the link in UITour to `about:accounts?action=email` when the method get `email` param. 

With that change, we won't break others call and fulfill this request.
Assignee: nobody → gasolin
Status: NEW → ASSIGNED
Flags: qe-verify+
Comment on attachment 8905745 [details]
Bug 1392959 - send action=email when UITour called with email option;

https://reviewboard.mozilla.org/r/177546/#review182748

Looks fine to me but please modify the comment.

::: browser/components/uitour/UITour.jsm:562
(Diff revision 2)
>        }
>  
>        case "showFirefoxAccounts": {
> -        // 'signup' is the only action that makes sense currently, so we don't
> +        let p;
> +        if (data.email) {
> +          // 'email' action help FxA determine whether the email is registered or not

Let's change the comment to avoid confusion within the else clause.

`With email parameter added, we need to use 'email' action to help FxA determine whether the email is registered or not.`
Attachment #8905745 - Flags: review?(rexboy) → review+
Flags: needinfo?(adavis)
Pushed by flin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fc6d97762cdb
send action=email when UITour called with email option;r=rexboy
https://hg.mozilla.org/mozilla-central/rev/fc6d97762cdb
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
I have verified that this issue is no longer reproducible on Win 10 x64, Win 7 x86, Mac 10.13, & Ubuntu 16.04 x32 with Firefox 58.
I can confirm the intended behavior is respected on beta. I verified using Fx 57.0b7 on Windows 10 x64, Ubuntu 14.04 LTS and macOS X 10.12.6.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Depends on: 1411714
You need to log in before you can comment on or make changes to this bug.