Closed Bug 1393491 Opened 2 years ago Closed 2 years ago

adbhelper broken after addon SDK removal

Categories

(DevTools :: WebIDE, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1393501

People

(Reporter: eeejay, Unassigned)

References

Details

adbhelper depends on sdk/system/child_process/subprocess which was removed from the gecko tree recently.
Whiteboard: [nosdk]
See Also: → 1393497
Thanks for tracking the root cause, we are almost done with removing SDK dependencies from DevTools but we totally missed ADB Helper and Valence.

Let's keep this bug to fix ADB Helper, this means find the easiest way to release a working version of ADBHelper.
I will log another bug to cleanup ADBHelper from all the addonsdk dependencies.

List of SDK requires in ADB Helper:
- https://github.com/mozilla/adbhelper/search?utf8=%E2%9C%93&q=require+sdk&type=
Whiteboard: [nosdk] → [nosdk] [triage]
For the subprocess module we can probably use Subprocess.jsm (http://searchfox.org/mozilla-central/source/toolkit/modules/subprocess/Subprocess.jsm).

It worth to mention that in Bug 1309351 the SDK subprocess module has been rewritten to be a thin wrapper of that jsm (in particular this commit https://hg.mozilla.org/releases/mozilla-aurora/rev/a1e968b6978b).
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Whiteboard: [nosdk] [triage]
Duplicate of bug: 1393501
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.