Closed Bug 1393952 Opened 3 years ago Closed 3 years ago

Give search-bar focus when opening (or switching to) Bookmarks Library

Categories

(Firefox :: Bookmarks & History, defect)

57 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 284653

People

(Reporter: gwmfms6, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.101 Safari/537.36

Steps to reproduce:

I opened the Bookmarks Library by tapping Ctrl+Shift+O (on Linux).


Actual results:

The search-bar in upper right corner area (the bar that says "Search Bookmarks") did not have focus.


Expected results:

When Bookmarks Library is opened, focus should default to the search-bar. Other windows that default to the search-bar include opening a New Tab and opening Preferences. Opening Bookmarks Library should also behave this way.

Also, whenever Ctrl+Shift+O is tapped, the Bookmarks Library should be opened (if already opened, then it should be brought front & center) AND the focus should be given to the search-bar. So if a user previously opened Bookmarks Library, and taps Ctrl+Shift+O to bring the Bookmarks Library back into view, focus should be put into the search-bar (if it wasn't there already).
Component: Untriaged → Bookmarks & History
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 284653
You need to log in before you can comment on or make changes to this bug.