Closed Bug 1394451 Opened 2 years ago Closed 2 years ago

Update Illustration for error: connection failure

Categories

(Firefox :: General, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 57
Iteration:
57.3 - Sep 19
Tracking Status
firefox57 --- fixed

People

(Reporter: ewright, Assigned: johannh)

References

(Blocks 1 open bug)

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(2 files)

No description provided.
Based on copy and mocks found in Bug 1358293
Whiteboard: [photon-visual][triage]
Flags: qe-verify-
Priority: -- → P3
Whiteboard: [photon-visual][triage] → [reserve-photon-visual]
Erica, will you have time to work on this this week or should we find someone else to take care of the bug? I'm asking because we have one week left to land all the new copy before string freeze :)

Thanks!
Flags: needinfo?(ewright)
(In reply to Johann Hofmann [:johannh] from comment #2)
> Erica, will you have time to work on this this week or should we find
> someone else to take care of the bug? I'm asking because we have one week
> left to land all the new copy before string freeze :)
> 
> Thanks!

Yes, that is my intention. There are three related patches waiting on reviews at the moment, and since they are similar I wanted to get those three approved before moving on to the rest. Hopefully I can get to this one soon.
Flags: needinfo?(ewright)
Great, thanks!
please use this for the illustration
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Priority: P3 → P1
Iteration: --- → 57.3 - Sep 19
It's not clear to me when this error should be shown, the copy suggests that this is shown in a situation where the user has no internet connection. It's most likely, however, that the user will get a DNS error (bug 1394462) in this case instead of this connection failure. The old copy for connection failure also points to the website being offline as the primary reason.

Am I missing something?
Flags: needinfo?(mheubusch)
Confirming with necko folks on IRC, a DNS error/NS_ERROR_UNKNOWN_HOST is most likely what people see when they're offline and a connection failure (e.g. NS_ERROR_CONNECTION_REFUSED) is rarely caused by being offline, so the proposed copy isn't really accurate, I'd say.
OK, then you'll need to help me out here.  Are you saying that this entire error message is moot? Or that the copy and illustration are more appropriate for a different error and that we should reapply this content to that error state? feel free to reach out to me on slack (mheubusch) if you want to discuss.
Flags: needinfo?(mheubusch)
Talked to Michelle on Slack, we will defer the copy changes to later and talk to Necko people about how we can enable showing the right error messages here. We'd still like to update the Dinosaur.
Summary: Update Illustration and copy for error: connection failure → Update Illustration for error: connection failure
Comment on attachment 8910353 [details]
Bug 1394451 - Add an illustration to net errors.

https://reviewboard.mozilla.org/r/181814/#review187186

Works on my end! thank you.
Attachment #8910353 - Flags: review?(ewright) → review+
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/48290c6e4a03
Add an illustration to net errors. r=ewright
https://hg.mozilla.org/mozilla-central/rev/48290c6e4a03
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
You need to log in before you can comment on or make changes to this bug.