If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

IRC connection limit bump for *.hashbang.sh

RESOLVED FIXED

Status

Infrastructure & Operations
Infrastructure: IRC
RESOLVED FIXED
22 days ago
15 days ago

People

(Reporter: vandor2012, Assigned: daveio)

Tracking

Details

(Reporter)

Description

22 days ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.90 Safari/537.36

Steps to reproduce:

Connect to the IRC server from a hashbang.sh server


Actual results:

When connecting to the server, the following message is given:

> =!= Closing link: (unknown@104.245.37.138) [Too many connections from your IP (global class). If you have a Mozilla LDAP account, you can get a temporary exemption here: https://iplimit.irc.mozilla.org/]


Expected results:

Connection to the server should be established

*Note:* Users can be identified on a per-user basis by using the `ident` protocol. Because each user are all required to use a shared IP (on a per-server basis, with currently four servers), the `113` port (as well as any port under 1024) is reserved for the `oidentd` daemon, configured to disallow spoofing.
(Assignee)

Comment 1

15 days ago
Each node listed on https://hashbang.sh/server/stats now has an IP limit matching its maxusers.

# hashbang.sh, bug 1394633, IPs listed in https://hashbang.sh/server/stats
<connect parent="main" allow="45.58.35.111" localmax="500" globalmax="500" limit="500" modes="+x">
<connect parent="main" allow="45.58.38.224" localmax="500" globalmax="500" limit="500" modes="+x">
<connect parent="main" allow="104.245.35.240" localmax="500" globalmax="500" limit="500" modes="+x">
<connect parent="main" allow="104.245.37.138" localmax="500" globalmax="500" limit="500" modes="+x">
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 days ago
Resolution: --- → FIXED
(Assignee)

Updated

15 days ago
Assignee: infra → dwilliams
You need to log in before you can comment on or make changes to this bug.