navigating to a long url by clicking on it in the JSON viewer does not work

RESOLVED DUPLICATE of bug 1394094

Status

()

Firefox
Developer Tools: JSON Viewer
RESOLVED DUPLICATE of bug 1394094
3 months ago
3 months ago

People

(Reporter: glob, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 months ago
Created attachment 8902254 [details]
long_url.json

navigating to a long url by clicking on it in the JSON viewer does not work.

steps to reproduce:

1. ensure devtools.jsonview.enabled is true
2. navigate to a json document containing a long url (eg. the attached file)
3. click on the url

expected result:

either the url should change to an input/text field so it can be copied, or the browser navigates to that url

actual result:

browser navigates to a malformed url

-

in the attachment i have http://www.glob.com.au.s3-website-us-east-1.amazonaws.com/

the json viewer initially shows this as a complete url, however after clicking on it, but before navigation, this changes to http://www.glob.com.au.s…s-east-1.amazonaws.com/, which is the url the browser tries to visit - http://www.glob.com.au.xn--ss-east-1-g674c.amazonaws.com/
(Reporter)

Comment 1

3 months ago
oh, this is with the latest nightly - 57.0a1 (2017-08-29) (64-bit), on osx.

Comment 2

3 months ago
Bug 1394094 will fix links of collapsed strings.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1394094
You need to log in before you can comment on or make changes to this bug.