Closed Bug 1394918 Opened 4 years ago Closed 4 years ago

Flash loses mouse events after minimize

Categories

(Core :: Plug-ins, defect)

55 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1358736
Tracking Status
firefox55 --- fixed
firefox56 --- wontfix
firefox57 --- wontfix

People

(Reporter: nicolas.dionbouchard, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: flashplayer, regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36

Steps to reproduce:

I'm on Windows 10, FF 55.0.3 (32 bits) with Flash 26.0.0.151.

I open a pop-up that uses Flash (full page). I minimize the Window, wait a second, then bring it back.


Actual results:

Flash does not respond to any mouse events (move, hover, clicks). I can event use a right click to bring Flash's menu and go to Settings. The panel opens but I'm unable to click any button in it.


Expected results:

Normal mouse events reactions. If I reload the page, everything is back to normal. I sometimes was able to gain events back after resizing the window or opening de Debug tools window but that doesn't work all the time.

Further note: the bug was reported to me when I had FF 54.x installed. I tried it and it was working fine. It's only after I updated to FF 55 that I got the bug.
Component: Untriaged → Plug-ins
Product: Firefox → Core
See Also: → 1394091
Jimm mentioned this may be related to async drawing and he will take a look after the platform triage meeting.
Blocks: 1394408
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1358736
This should be fixed in the latest flash beta 27.
You need to log in before you can comment on or make changes to this bug.