History items selection does not work for search field when put in the "More tools…" drawer

RESOLVED DUPLICATE of bug 1390336

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 1390336
4 months ago
4 months ago

People

(Reporter: Étienne Deparis, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170829100404

Steps to reproduce:

1. Customize the toolbar by adding the search field in the new "More tools…" drawer (the button with the » icon, at the left of the burger menu).
2. Hit Ctrl+K. The drawer opens and the search field is focused
3. Type a few word you already looked for previously
4. Some reminder appear just bellow.


Actual results:

If I hit the down key, the search field loses its focus, nothing is selected, the proposals areas is closed and I have to hit Ctrl+K again or click into the search field to gain focus again.

If I hit the Tab key, I move directly to the search engine selection line, which seems to be the intended behavior.


Expected results:

If I hit the down key, the focus should be given to the first result of the history list, hitting the down key again should give the second results etc. After that, hitting the enter key must put the selected content in the search field and directly fire the research.

OR doing nothing with the down key BUT in that case, hitting Tab should navigate through proposed results before entering the search engine selection line.

Updated

4 months ago
Status: UNCONFIRMED → NEW
Component: Untriaged → Search
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1390336
You need to log in before you can comment on or make changes to this bug.