When right-clicking page, "Back" and other items are gone (Chrome 60)

RESOLVED WORKSFORME

Status

enhancement
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: danielkaspo, Unassigned)

Tracking

Details

(Whiteboard: [specification][type:change])

Attachments

(2 attachments)

Reporter

Description

2 years ago
What feature should be changed? Please provide the URL of the feature if possible.
==================================================================================
Any wiki page - if right-clicked on will show the issue.

https://developer.mozilla.org/en-US/docs/MDN/Feedback

One example page, just right-click on it and you'll see it.

What problems would this solve?
===============================
I only have left and right click on my mouse. To go back a page, I will always right-click, move the mouse slightly down-right, and then click "Back"

Once I hit MDN during my browsing session though, I no longer can do that. Minor inconvenience but also a bad precedence to set (removing things from the right-click context menu.)

Who would use this?
===================
Every sane user.

What would users see?
=====================
A context menu they are familiar with and understand.

What would users do? What would happen as a result?
===================================================
Be able to use their context menus and whatever extensions they had in there. Also, basic functionality like going back and forward.

Is there anything else we should know?
======================================
This was a bad change to begin with and I'm sad to see MDN make it.
I'm unable to duplicate this on Firefox 57, Safari 10, or Chrome 60 on MacOS. On all those systems, a control-click opens the context menu, and back is one of the top options. I'll attach a screenshot.

What browser and OS are you using? Do you get different results if you click on different areas of the page?
Posted image Back - Chrome 60.png
"Back" is the first menu item on Chrome 60
Back is an Arrow in Firefox 57
Reporter

Comment 4

2 years ago
I'm on v60 of Chrome and it's happening on both Windows 10 and Ubuntu 16.04 for me.

http://imgur.com/ciIMIG4

That's a screenshot of what I'm seeing.
Reporter

Comment 5

2 years ago
(In reply to John Whitlock [:jwhitlock] from comment #1)
> I'm unable to duplicate this on Firefox 57, Safari 10, or Chrome 60 on
> MacOS. On all those systems, a control-click opens the context menu, and
> back is one of the top options. I'll attach a screenshot.
> 
> What browser and OS are you using? Do you get different results if you click
> on different areas of the page?

If it helps also, this is it while I'm in Incognito Mode (no extensions other than LastPass)

http://imgur.com/34KAC0w
That's interesting. Your screenshot shows the MDN context menu items. The Firefox screenshot shows how the feature is supposed to work - two menu items added, but the others remain as well. I don't see this issue on Chrome 60.0.3112.113 for MacOS. 

MDN documents the contextmenu attribute here:

https://developer.mozilla.org/en-US/docs/Web/HTML/Global_attributes/contextmenu

For Chrome we say it is not supported, with the note:

An experimental implementation was originally available via the command line option --enable-blink-features=ContextMenu. Until Chrome 52 and Opera 39 it was additionally available by enabling the Experimental Web Platform features option, but got removed from that due to a Web compatibility issue [1]. In June 2017, it was removed entirely from the browsers. This is documented in Chromium bug 87553.

[1] https://bugs.chromium.org/p/chromium/issues/detail?id=412945
[2] https://bugs.chromium.org/p/chromium/issues/detail?id=87553

Maybe the situation has changed again? Maybe MacOS will break on the the next Chrome update?
See Also: → 1370965
Summary: When right-clicking page, "Back" and other items are gone → When right-clicking page, "Back" and other items are gone (Chrome 60)
I'm not able to reproduce in Chrome 61 on Debian Stretch or Chromium 60 in Ubuntu 16.04.
Reporter

Comment 8

2 years ago
Upgraded Chrome from v60 to v61 and it's back to normal :)

https://imgur.com/lidPnQF
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.