The .txt files are printed wrong

RESOLVED FIXED in Firefox 57

Status

()

defect
--
major
RESOLVED FIXED
2 years ago
6 months ago

People

(Reporter: Ovidiu, Assigned: cfu)

Tracking

({regression})

57 Branch
mozilla57
All
Unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 fixed)

Details

Attachments

(2 attachments)

Reporter

Description

2 years ago
Posted image print output.jpeg
[Note]:
- 

[Affected versions]:

Nightly 57.0a1(2017-08-30)

[Affected platforms]:

Tested on Mac OS X 10.12 and Windows 10 x64

[Steps to reproduce]:

1. Go to this .txt example: http://mozqa.com/data/firefox/awesome_bar/diff.txt
2. Print it.

[Expected result]:

The test page is printed with very small letters. 

[Actual result]:
 
The letters from the print output should have the normal dimensions.  

[Regression range]:

This is a regression and here is the regression window:

Last good revision: 40bc1d4ce54b34b3851d52576e1b16f68af3bd48
29:04.30 INFO: First bad revision: bd9c5474a5e4e6391a3ae74574885d1361599184
29:04.30 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=40bc1d4ce54b34b3851d52576e1b16f68af3bd48&tochange=bd9c5474a5e4e6391a3ae74574885d1361599184



Note: Please see the attached file with the actual result.
Reporter

Comment 1

2 years ago
Chung-Sheng Fu from the regression range looks like one of your bags created this regression, can you please take a look at it? Thanks.
Flags: needinfo?(cfu)
Keywords: regression

Comment 2

2 years ago
After landing Bug 863246, 
Plain text file would not wrap by browser width.
So, It also be layout regression,
Blocks: 863246

Comment 3

2 years ago
Browser Console shows an error when open a .txt file:

Security Error: Content at http://mozqa.com/data/firefox/awesome_bar/diff.txt may not load or link to resource://gre-resources/plaintext.css.

Updated

2 years ago
Component: Printing: Output → Security
Assignee

Updated

2 years ago
Attachment #8903078 - Flags: review?(cam)
Assignee

Comment 5

2 years ago
After Bug 863246, web content is not able to load resource:// URIs by default.  resource://gre-resources/plaintext.css has to be loaded in web content so move it to a content-accessible folder.
Assignee: nobody → cfu
Flags: needinfo?(cfu)

Comment 6

2 years ago
mozreview-review
Comment on attachment 8903078 [details]
Bug 1395486 - Move resource://gre-resource/plaintext.css to resource://content-accessible/plaintext.css.

https://reviewboard.mozilla.org/r/174856/#review179924
Attachment #8903078 - Flags: review?(cam) → review+
Assignee

Updated

2 years ago
Keywords: checkin-needed
Reporter

Comment 7

2 years ago
Just a note, this issue is also reproducible on Ubuntu 16.04.

Comment 8

2 years ago
Any clue when will this be fixed in the nightly ?

Comment 9

2 years ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f3f991da060a
Move resource://gre-resource/plaintext.css to resource://content-accessible/plaintext.css. r=heycam
Keywords: checkin-needed

Comment 10

2 years ago
(In reply to ivivanov.bg from comment #8)
> Any clue when will this be fixed in the nightly ?

It just landed on autoland. It'll be fixed on the first nightly after it merges. Hopefully that will be either today's "late" nightly (but that's pretty unlikely) and otherwise tomorrow's nightly - that's assuming no automated tests fail or other issues crop up that cause it to be backed out.

Comment 11

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f3f991da060a
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57

Updated

2 years ago
Depends on: 1395286
https://hg.mozilla.org/integration/mozilla-inbound/rev/5cc81a8efe158d3ea9504251cb3563d1a474e4b6
Bug 1395486 followup. Clobber to fix packaging failure for Android builds. r=clobber

Comment 13

2 years ago
Pushed by mozilla@buttercookie.de:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5cc81a8efe15
followup. Clobber to fix packaging failure for Android builds. r=clobber
You need to log in before you can comment on or make changes to this bug.