Status

()

Core
Memory Allocator
--
critical
RESOLVED DUPLICATE of bug 1229384
6 months ago
5 months ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

Trunk
Unspecified
Windows 10
crash
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

This bug was filed from the Socorro interface and is 
report bp-5eec4421-0b39-4a74-9120-eaecc0170901.
=============================================================

Seen while looking at crash stats: http://bit.ly/2emUlle. Crashes started using 20170831100258. 31 crashes/12 installs.

Possible regression from Bug 1395063?
Flags: needinfo?(mh+mozilla)
As mentioned in the commit message in bug 1395063, it changed the crash signatures, so instead of having crashes in moz_abort that come from page_commit, you now have crashes in page_commit directly.
Flags: needinfo?(mh+mozilla)
See also bug 1395805.

glandium, is this likely to be generic heap corruption?
Flags: needinfo?(mh+mozilla)
More like OOM. (VirtualAlloc failing)
Flags: needinfo?(mh+mozilla)
I'll file a bug to get something added to the Socorro prefix list so these different overcommit crashes don't end up in a single bucket, like they were before.
See Also: → bug 1395063
(In reply to Andrew McCreight [:mccr8] from comment #6)
> I'll file a bug to get something added to the Socorro prefix list so these
> different overcommit crashes don't end up in a single bucket, like they were
> before.

Well, I guess that doesn't make too much sense. I didn't realize the old signature also wasn't going very far on the prefix list. I'll just dupe this over to the old bug for this signature, and add the signature.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1229384
Crash Signature: [@ pages_commit]

Comment 9

5 months ago
1 failures in 943 pushes (0.001 failures/push) were associated with this bug in the last 7 days.    

Repository breakdown:
* mozilla-beta: 1

Platform breakdown:
* windows7-32-stylo-disabled: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1395778&startday=2017-09-18&endday=2017-09-24&tree=all
You need to log in before you can comment on or make changes to this bug.