All users were logged out of Bugzilla on October 13th, 2018

Customize mode icons get placed incorrectly one spot to the left in the palette

NEW
Unassigned

Status

()

P4
normal
a year ago
9 months ago

People

(Reporter: ewright, Unassigned)

Tracking

({regression})

57 Branch
regression
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox55 wontfix, firefox56 wontfix, firefox57 wontfix, firefox58 wontfix, firefox59 ?)

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8903577 [details]
customize-icons-shift.mp4

Dragging and dropping icons in customize mode.

when dropping the icon, it gets positioned one spot to the left of where it is actually being dropped.

Comment 1

a year ago
Does this only happen in the palette? Or also on toolbars / in the overflow panel?
Flags: needinfo?(ewright)
(Reporter)

Comment 2

a year ago
(In reply to :Gijs (queue backed up, slow) from comment #1)
> Does this only happen in the palette? Or also on toolbars / in the overflow
> panel?

It only happens in the palette.
Flags: needinfo?(ewright)

Updated

a year ago
status-firefox55: --- → ?
status-firefox56: --- → affected
Flags: needinfo?(gijskruitbosch+bugs)
Keywords: regression, regressionwindow-wanted
Summary: Customize mode icons get placed incorrectly one spot to the left → Customize mode icons get placed incorrectly one spot to the left in the palette

Comment 3

a year ago
I think this is not a regression.
I can reproduce this problem with Firefox 29. It has been since Australis Marge.
(Prior to Australis, the dropped icon is always at the very end regardless of the drop position)

Comment 4

a year ago
(In reply to Alice0775 White from comment #3)
> I think this is not a regression.
> I can reproduce this problem with Firefox 29. It has been since Australis
> Marge.
> (Prior to Australis, the dropped icon is always at the very end regardless
> of the drop position)

Indeed, this is true for trying to drop items at the end, but not for putting items in the middle. The animation and placement there broke at some point, I think. I'm not clear on why that happened, but it's probably one of my patches.

Updated

a year ago
Blocks: 1354082
status-firefox55: ? → wontfix
Keywords: regressionwindow-wanted
Whiteboard: [photon-structure][triage]
Flags: qe-verify?
Priority: -- → P4
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]
Flags: qe-verify? → qe-verify+
QA Contact: gwimberly
status-firefox56: affected → wontfix
status-firefox57: affected → wontfix
status-firefox58: --- → fix-optional

Comment 5

10 months ago
The animation etc. in general got fixed in bug 1415056. However, the specific case of items at the bottom + end of the list is harder to fix. I looked into this for a while and gave up, given that it's likely we'll rearchitect the whole lot of this in bug 1388154. So clearing ni.
Flags: needinfo?(gijskruitbosch+bugs)
You need to log in before you can comment on or make changes to this bug.