Closed Bug 1396281 Opened 2 years ago Closed 2 years ago

Windows control buttons do not follow Fitts' law

Categories

(Firefox :: Theme, defect, major)

57 Branch
All
Windows 10
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 + fixed

People

(Reporter: Eddwardiq, Assigned: yzen)

References

Details

(6 keywords)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170902100317

Steps to reproduce:

Impossible to click on Windows control buttons (min,max,close) when mouse cursor is on the top edge of window above them (maximized mode). The same applies to the top right corner. 
Possible suspect Bug 1383051.
Blocks: 1383051
Component: Untriaged → Theme
Keywords: regression
[Tracking Requested - why for this release]:
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 1396369
(In reply to Kestrel from comment #3)
> Created attachment 8904015 [details]
> window-controls-comparison.png

yes, this is how it looks in touch mode
Duplicate of this bug: 1396400
Regressed by Bug 1383051
Severity: normal → major
Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(yzenevich)
OS: Unspecified → Windows 10
Hardware: Unspecified → All
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
Flags: needinfo?(yzenevich)
Hi, 

I noticed issue slightly related to this one. When I hover mouse over exit button I get result like on screenshot (exit.png) pretty good, but there is no standard Windows's "exit" (or "close", not sure which one it is on ENG Windows) tool-tip that normally is visible with other windows. Second problem is that when I hover on the right edge of the window I can actually hover button which apparently is underneath see (exit2.png) and in this case I get "exit" tool-tip. Also Firefox's window buttons are little bit laggy when you move your mouse pointer away very fast. Native Windows's windows works better.
Attached image exit.png
Attached image exit2.png
Actually, I'm not seeing tooltips on ANY of the Windows control buttons in the upper right corner.
This interferes with the photon-visual work. Please fix this asap.
Missing tooltips is Bug 1301569.
(In reply to Dão Gottwald [::dao] from comment #12)
> This interferes with the photon-visual work. Please fix this asap.

Hi Dão, I can only get to it (which should be a small fix) this weekend, latest Monday. I'm also happy to back out bug 1383051 changes.
Flags: needinfo?(dao+bmo)
(In reply to Yura Zenevich [:yzen] from comment #14)
> (In reply to Dão Gottwald [::dao] from comment #12)
> > This interferes with the photon-visual work. Please fix this asap.
> 
> Hi Dão, I can only get to it (which should be a small fix) this weekend,
> latest Monday. I'm also happy to back out bug 1383051 changes.

Okay, please back it out.
Flags: needinfo?(dao+bmo) → needinfo?(yzenevich)
Nevermind, I backed this out for you:

https://hg.mozilla.org/integration/mozilla-inbound/rev/f35b580b376237ef4f21b720b1e552fedf6c3e90
https://hg.mozilla.org/integration/mozilla-inbound/rev/f090a933bbaeb03c0c5e41a654e226cf9ecf32df
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(yzenevich)
Resolution: --- → FIXED
Duplicate of this bug: 1397695
Duplicate of this bug: 1397873
Fixed on latest Nightly.
Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox 57
You need to log in before you can comment on or make changes to this bug.