Crash while dropping click-dragged selected text [@ CGSReleaseRegion]

RESOLVED WORKSFORME

Status

()

Core
Drag and Drop
--
critical
RESOLVED WORKSFORME
17 years ago
11 years ago

People

(Reporter: Emlyn Shannon, Unassigned)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0rc1)
Gecko/20020421
BuildID:    2002042105


Reproducible: Sometimes
Steps to Reproduce:
1. Highlight some text.
2. Drag a short distance (seems to work better when dragging horizontally).
3. Realease.
4. Crash.

Actual Results:  Crash

Expected Results:  Nothing

Apple's crash reporter had this to say:


Thread 0 Crashed:
 #0   0x77181e50 in CGSReleaseRegion
 #1   0x73d7bd8c in DisposeDragRegion
 #2   0x73d7e738 in MessageHandler
 #3   0x701a4894 in __CFMessagePortPerform
 #4   0x7018f3b0 in __CFRunLoopDoSource1
 #5   0x7017c1e0 in __CFRunLoopRun
 #6   0x701b7100 in CFRunLoopRunSpecific
 #7   0x7017b8e0 in CFRunLoopRunInMode
 #8   0x7312d8f4 in RunEventLoopInModeUntilEventArrives
 #9   0x731c2bbc in RunEventLoopUntilEventArrives
 #10  0x731a1340 in GetNextEventMatchingMask
 #11  0x731232d0 in EventAvail
 #12  0x01bfaa4c in nsMacMessagePump::GetEvent(EventRecord &)
 #13  0x01bfa9ac in nsMacMessagePump::DoMessagePump(void)
 #14  0x01bfa33c in nsAppShell::Run(void)
 #15  0x01b1f20c in nsAppShellService::Run(void)
 #16  0x004c9aec in main1(int, char **, nsISupports *)
 #17  0x004ca52c in main

Thread 1:
 #0   0x7000497c in syscall
 #1   0x70557600 in BSD_waitevent
 #2   0x70554b80 in CarbonSelectThreadFunc
 #3   0x7002054c in _pthread_body

Thread 2:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x705593ec in CarbonOperationThreadFunc
 #3   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x70283ea4 in TSWaitOnConditionTimedRelative
 #3   0x7027d748 in TSWaitOnSemaphoreCommon
 #4   0x702c2078 in TimerThread
 #5   0x7002054c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x70250ab0 in TSWaitOnCondition
 #3   0x7027d730 in TSWaitOnSemaphoreCommon
 #4   0x70243d14 in AsyncFileThread
 #5   0x7002054c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7055b884 in CarbonInetOperThreadFunc
 #3   0x7002054c in _pthread_body

Thread 6:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x7017bf98 in __CFRunLoopRun
 #3   0x701b7100 in CFRunLoopRunSpecific
 #4   0x7017b8e0 in CFRunLoopRunInMode
 #5   0x7061be08 in
XIOAudioDeviceManager::NotificationThread(XIOAudioDeviceManager *)
 #6   0x706141c0 in CAPThread::Entry(CAPThread *)
 #7   0x7002054c in _pthread_body

Thread 7:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x70026a2c in _pthread_become_available
 #3   0x70026724 in pthread_exit
 #4   0x70020550 in _pthread_body

PPC Thread State:
  srr0: 0x77181e50 srr1: 0x0200d030                vrsave: 0x00000000
   xer: 0x0000000c   lr: 0x77181e44  ctr: 0x77181e30   mq: 0x00000000
    r0: 0x73d7bd8c   r1: 0xbfffea30   r2: 0xbfffea38   r3: 0x00000001
    r4: 0x00000000   r5: 0x00000004   r6: 0x0000002c   r7: 0x00000e03
    r8: 0x00000000   r9: 0x0335fdf0  r10: 0x0008e1a0  r11: 0x83d7026c
   r12: 0x77181e30  r13: 0x00000000  r14: 0x00000000  r15: 0x00000000
   r16: 0x00000001  r17: 0x00000000  r18: 0x00000000  r19: 0x00000000
   r20: 0xbfffed98  r21: 0x00000000  r22: 0x8016024c  r23: 0x00000000
   r24: 0x0335fdf0  r25: 0x00000000  r26: 0x00000000  r27: 0x00000000
   r28: 0x83d70040  r29: 0x00000002  r30: 0x0335fdf0  r31: 0x77181e44

Comment 1

17 years ago
sounds like bug 81779

stack doesn't look the same though

Comment 2

17 years ago
possible dup of bug 81779.
Related: bug 140275

Comment 3

17 years ago
WorksForMe using FizzillaCFM/2002041712 (RC1).
Keywords: crash
(Reporter)

Comment 4

17 years ago
I still see this on 20020429 (RC 1) Same stacktrace as before.

Try selecting larger blocks of text.

Comment 5

17 years ago
I have begun to see this too on builds from the 30th of April. I am using
Windows 98. I have never seen this before.

If I click and drag text even a short distance (within Navigator), and then
release it the whole browser becomes unresponsive. I have to then shut it down
using Ctrl Alt Del. 

This seems like a serious instability problem which I have never seen before. I
am completely stumpted as to which this has suddenly crept in. 
Created attachment 82102 [details]
CrashReporter - crash while dragging

Attaching CrashReporter log with a crash in the same function, but a different
stack.	I don't believe I had let go of the drag yet.
doh.  This was using FizzillaCFM/2002041712 (RC1).
Hmmm, after this crash I can't do anything with my Desktop.  If I click on it, I
just get beeps, without Mozilla even running.   Relaunching the Finder clears it up.

Is everyone here running 10.1.4?  I'm on a G4/400.

Comment 9

16 years ago
I just downloaded the latest (stable)nightly 1.0 branch build (as opposed to the
'unstable' trunk builds) and this problem seems to have vanished. Vanished! Wow
- I am so happy when bugs seem to fix themselves! I am amazed ! I will keep
trying to get back the old behavior (total browser unresponsivness on selecting
and dragging text.) I will keep all of you posted.

Comment 10

16 years ago
Regarding comment 5: That was bug 141455

Comment 11

16 years ago
Emlyn and Bill, can you confirm Jayesh's report of this problem no longer being
evident?
Greg, check out comment #10, which refers to comment #5 and comment #9, by
extention; Jayesh was talking about another bug.
(Reporter)

Comment 13

16 years ago
Indeed, he was talking about a different bug, and I still see this on RC2
2002051105. Can we at least get this confirmed?

Comment 14

16 years ago
Still WFM using RC2. Visited [http://www.mozillazine.org/], selected all text on
the page, dragged both short and long distances and released, with no crash.

Comment 15

16 years ago
Sending to XP Apps: Drag and Drop.
Assignee: Matti99 → blaker
Component: Browser-General → XP Apps: Drag and Drop
QA Contact: imajes-qa → tpreston
Summary: Crash while dropping click-dragged selected text → Crash while dropping click-dragged selected text [@ CGSReleaseRegion]
(Reporter)

Comment 16

16 years ago
I can't reproduce this in 1.1a, but it might still be present in the 1.0 branch.
Should I find out more, or forget the whole thing?

Comment 17

16 years ago
Emlyn, if you can still reproduce this using 1.0, that's significant, and it
should be addressed.

If you can, it would be worth it to try 1.0 builds on other platforms, like Mac
OS 9 or Windows.
Created attachment 93701 [details]
CrashReporter from Mozilla 1.1b

Just got this again under 1.1b (Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US;
rv:1.1b) Gecko/20020723).  I was dragging a short distance, didn't go out of
the mozilla window (I intended to drag out, but lost the mouse button just
after starting the drag).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 19

16 years ago
qa contact -> pmac
QA Contact: tpreston → pmac
Assignee: bross2 → nobody
QA Contact: pmac
In response to the private mail I got on this bug, yes, the problem appears to be gone for me.  I'm on FF3b2 now and haven't seen this problem for quite some time.

Comment 21

11 years ago
WFM then per Bill (because reporter is gone - email address is dead).
Thanks Bill.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ CGSReleaseRegion]
You need to log in before you can comment on or make changes to this bug.