labels doesn't hold when moved (via filter) -- suspect cross account move

VERIFIED DUPLICATE of bug 127141

Status

MailNews Core
Filters
VERIFIED DUPLICATE of bug 127141
16 years ago
10 years ago

People

(Reporter: Henrik Gemal, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
if you make a filter that as the first rule sets a label to all mails only the 
mails that doesn't hit another filter that moves messages into another folder 
are labeled.

Say to have two filters:
1) label all mails "personal"
2) move all mails with "spam" in the subject to the "spam" folder

now all the mails in the inbox are labeled "personal" but none of the mails in 
the "spam" folder are labeled "personal"

20020421

Comment 1

16 years ago
Where is your spam folder?  We have issue where cross account moves will not
move the filter -- see bug 127141.  Your summary is incorrect -- the label
filter does work, it's the move which won't hold the label and that is the same
even when manually moving a labeled message.

Summary: labels doesn't work with filters → labels doesn't hold when moved (via filter) -- suspect cross account move
(Assignee)

Comment 2

16 years ago
yes imap--> local loses the label flag. within the same acct it works fine. 
(Reporter)

Comment 3

16 years ago
>within the same acct it works fine.

not on my IMAP server (Exchange)

spam folder is on the same server. I dont move any messages cross server, just
into a folder on the same server

Comment 4

16 years ago
There are some servers which don't store labels, exchange is likely one of them.
cc ssu and bienvenu

Comment 5

16 years ago
an imap protocol log will determine if your server supports labels or not

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

*** This bug has been marked as a duplicate of 127141 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.