Labels lost on cross-account move/copy (except local to local)

VERIFIED FIXED

Status

MailNews Core
Backend
VERIFIED FIXED
16 years ago
6 years ago

People

(Reporter: laurel, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Using feb21 commercial trunk build

Issue found while verifying related bug 114379

Moving or copying a labeled message will not retain label in destination when
filing across accounts in these situations:
1. Cross account IMAP-->any other account (including Local Folders) loses label.
2. Cross account POP-->POP (including Local Folders) is okay.
3. Cross account POP-->IMAP loses label.
4. Copy News-->any account loses label.
(Reporter)

Updated

16 years ago
QA Contact: esther → laurel

Comment 1

16 years ago
Related bug 114379 (which probably should depend on this bug) was marked
nsbeta1+. Therefore, I suggest to also mark this bug nsbeta1+.
(Assignee)

Comment 2

16 years ago
This bug is much more specific and limited to the special case of copying imap
messages to local folders or other imap accounts, Peter. This is obviously  much
rarer than copying messages between imap folders on the same server. I don't see
why you think this would automatically qualify for nsbeta1+

Comment 3

16 years ago
Huh, I didn't realize that - sorry. I actually thought that this bug covers the
more common occurrences. I copy from IMAP -> Local *much* more often than IMAP
-> IMAP.

Since fixing bug 114379 may just make this one seem even worse, could we have a
KW: mozilla0.9.9?
(Assignee)

Comment 4

16 years ago
fixing 114379 has absolutely nothing to do with this bug (it doesn't make it
better or worse - it just allows most users to have their labels maintained when
copying messages between folders). And remember, you're not a typical user. IMAP
is meant for storing your messages on the server. Otherwise, you'd just be using
POP3.

Comment 5

16 years ago
I did say: "seem" worse. But I also see your point about how most IMAPs are used.
(Reporter)

Updated

16 years ago
Keywords: relnote
(Assignee)

Comment 6

16 years ago
*** Bug 139674 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
I disagree w/comment #4 regarding "typical" IMAP usage, "IMAP
is meant for storing your messages on the server. Otherwise, you'd just be using
POP3".  I don't think most users have a choice between IMAP and POP, their IT
department or ISP makes that decision.  Also, local folders might be used to
archive messages (especially if there is a server-imposed quota).

Comment 8

16 years ago
> especially if there is a server-imposed quota

Which is almost always the case. I could NEVER afford to keep all my messages
(300+ MB) in my IMAP folders (10 MB limit).

PS could someone nominate this bug (mozilla1.1, nsbeta) to get it on the radar?
This bug greatly devalues the usefulness of labels.
(Reporter)

Comment 9

16 years ago
*** Bug 150725 has been marked as a duplicate of this bug. ***

Comment 10

14 years ago
I agree with Comment #8 that "This bug greatly devalues the usefulness of labels".

This bug affects me daily, still 2 years later, as I usually work like this:

I download new mails from my ISV's "publicly" accessible POP account to my
laptop, from either at Home, at Work, or "on the Run". Handle them there, and
now and then, when connected to my Home Server running IMAP at Home, run some
filters that save mails of interest to my Mail Archives residing on the IMAP
account for future reference. Everything not explicitly handled within a certain
timeframe is then deleted from the POP Client Account on the laptop by running
another mail filter. UNFORTUNATELY I loose the all the labels during the
"archival process" as long as this bug has not become fixed.

I'd like to see this bug fixed sometime soon now. Shouldn't be too hard to solve
 - or? And considering that it must explicitly be mentioned in the "Mozilla
Release Notes" it's obviously an important one to fix.
(Assignee)

Comment 11

14 years ago
Created attachment 138671 [details] [diff] [review]
proposed fix

when uploading to an imap server, if the msg hdr has a label set, try to set
the label on the server.
(Assignee)

Updated

14 years ago
Attachment #138671 - Flags: superreview?(mscott)

Updated

14 years ago
Attachment #138671 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 12

14 years ago
fix checked in.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
*** Bug 230185 has been marked as a duplicate of this bug. ***

Comment 14

14 years ago
Does this patch address the original poster's specifications?

1. Cross account IMAP-->any other account (including Local Folders) loses label.
2. Cross account POP-->POP (including Local Folders) is okay.
3. Cross account POP-->IMAP loses label.
4. Copy News-->any account loses label.

If not (especially IMAP -> Local Folders), then I don't consider this bug fixed.
(Assignee)

Updated

14 years ago
Blocks: 230700
(Assignee)

Comment 15

14 years ago
fixed on m4 branch.

Comment 16

14 years ago
I've just tried to copy and move messages with labels between POP3 and IMAP
accounts with Mozilla 1.7rc2 (2004051508), running on Windows/NT 4.0 sp6a, and -
guess what - labels are not keept (at least they are not visually reflected by
the Mozilla user interface).

Therefore I find it very surprising that this Bug Report has a status of
'Resolved'. To my findings this issue is NOT RESOLVED.

If this really is 'Resolved' and is working, then I must be doing something
wrong and then please let me know how to do this in order to not loose my labels
when moving/copying my messages back and forth between an IMAP account and a
POP3 account, and vice versa. 

Should there be a new Bug Report for this same issue, then please let me know too.
(Assignee)

Comment 17

14 years ago
Rolf, does your imap server support labels/user defined keywords stored on the
server? If not, we can't store the label on the server...

Comment 18

14 years ago
The IMAP Server is WU-IMAP-2004 running on Solaris.

If this server doesn't support the storing of labels, then what IMAP server are
the rest of you running?

How are the labels stored?

Comment 19

14 years ago
I’m using an account to connect to a Microsoft Exchange Server using IMAP and
also loose my labels, moving messages either from a server folder to a local one
or the opposite. As to flags, they’re not lost moving from server to local, but
are lost doing the opposite. Are these behaviours to expect, and unsolvable, or
should I open a bug? The so-called “follow-up flags” in MS Outlook (similar to
labels, but less friendly, as no colours are associated with them) are always
correctly kept, whatever the move; but then again, that’s probably not
surprising, everything taking place in Microsoftdom... Thanks.
(Assignee)

Comment 20

14 years ago
what build are you using? I've fixed this for imap servers that don't support
user defined keywords as well, in 1.8a, I believe.

Comment 21

14 years ago
Yes, I should have included this:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616
Going to try 1.8a without delay... Thanks

Comment 22

14 years ago
Now using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040714
The behaviour improved: both labels and flags are kept when moving from server
to local, but both are lost when moving from local to server. Anyway, this is
enough for me: all I want is to move a few hundred messages from a local folder
to the server, to access them from home. Many thanks.

In case this is useful, verifying the IMAP connectivity with the Exchange
server, like this:
telnet exchange.computing.dundee.ac.uk 143
I get the following:
* OK Microsoft Exchange IMAP4rev1 server version 5.5.2653.23 (mailhost) ready

Comment 23

14 years ago
CORRECTION (and I promise this is my last post…): labels are kept when moving
from _local to server_, whereas flags are kept when moving from _server to local_.
Product: MailNews → Core

Comment 24

13 years ago
On Thunderbird 1.0 (20041206), I lose labels when moving from IMAP to local
folder. Should I file a new bug for Thunderbird or should this be reopened?
(In reply to comment #24)
> On Thunderbird 1.0 (20041206), I lose labels when moving from IMAP to local
> folder. Should I file a new bug for Thunderbird or should this be reopened?

yes, I also see this problem using 20050509-trunk builds --I couldn't find an
existing bug on it.

David, I can either reopen this or file a new bug, whichever you prefer.
(Assignee)

Comment 26

13 years ago
Sarah, I think I'd prefer a new bug with a summary that reflects the specific
problem (moving from imap to local?)
filed bug 293832.

verifying this particular bug (moving/copying IMAP to IMAP) works fine: tested
with 20050509-trunk tbird bits on mac os x 10.3.9.
Status: RESOLVED → VERIFIED

Comment 28

12 years ago
ok prob a dumb idea but couldn't we just modify the src message to add an X header label and have mozilla read this?

would also allow you to send a "to do" to someone else ;-)
(Assignee)

Comment 29

12 years ago
afaik, this is all fixed in 1.5
Product: Core → MailNews Core
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.