Use consistent search icon in type="search" textboxes

REOPENED
Unassigned

Status

()

Firefox
Theme
P2
normal
REOPENED
10 months ago
9 months ago

People

(Reporter: B.J. Herbison, Unassigned)

Tracking

({ux-consistency})

57 Branch
ux-consistency
Points:
---

Firefox Tracking Flags

(firefox57 affected, firefox58 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
The search icons across Firefox aren't consistent.

Left handed:
* URL bar icon for Nightly about:home.
* Search box in Nightly about:preferences.

Right handed:
* Icon for search box in the body of about:home.
* Left menu Search icon in Nightly about:preferences.

Discovery and image: Edds in Mozillazine forums.
http://forums.mozillazine.org/viewtopic.php?p=14765101#p14765101

Updated

10 months ago
Component: Untriaged → Theme
Keywords: ux-consistency

Updated

10 months ago
Whiteboard: [photon-visual][triage]

Comment 1

10 months ago
Created attachment 8904739 [details]
icons.png

Updated

10 months ago
Whiteboard: [photon-visual][triage]

Comment 2

10 months ago
(In reply to B.J. Herbison from comment #0)
> Right handed:
> * Icon for search box in the body of about:home.

Also about:newtab. I'm moving this to activity stream since I think the plan is to use activity stream for about:home.
Component: Theme → Activity Streams: Newtab

Updated

9 months ago
Depends on: 1399642
Duplicate of this bug: 1401397

Updated

9 months ago
Status: NEW → RESOLVED
Last Resolved: 9 months ago
status-firefox58: --- → affected
Priority: -- → P2
Resolution: --- → FIXED

Updated

9 months ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

9 months ago
Status: REOPENED → RESOLVED
Last Resolved: 9 months ago9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1399642
Depends on: 1403359

Comment 5

9 months ago
Reopening specifically for <textbox type="search"/> which uses its own different icon. This affects e.g. sidebars, about:preferences, and about:config.
Status: RESOLVED → REOPENED
Component: Activity Streams: Newtab → Theme
No longer depends on: 1403359
Resolution: DUPLICATE → ---
Summary: Use consistent search icon → Use consistent search icon in type="search" textboxes
You need to log in before you can comment on or make changes to this bug.