Search icon in awesomebar is not correct icon

VERIFIED FIXED in Firefox 57

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: k88hudson, Assigned: daleharvey)

Tracking

(Blocks 2 bugs)

unspecified
Firefox 58
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 verified, firefox58 verified)

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(1 attachment)

Reporter

Description

2 years ago
It looks like the icon is the awesome bar is not yet updated, it should be "chrome://browser/skin/find.svg" but it is "chrome://global/skin/icons/autocomplete-search.svg".
Reporter

Updated

2 years ago
Whiteboard: [photon-visual]
Whiteboard: [photon-visual] → [photon-visual] [triage]
Priority: -- → P3
Whiteboard: [photon-visual] [triage] → [reserve-photon-visual]
Priority: P3 → P4
Reporter

Comment 1

2 years ago
After further investigation we noticed that chrome://global/skin/icons/autocomplete-search.svg seems to be built differently on different OSs – would the correct fix here be to update find.svg to support both or to update the file resolving to that path to be the right icon/colour?

I'm asking since we'd like to use the same icon on the search box in about:newtab / activity stream
Reporter

Updated

2 years ago
Flags: needinfo?(dao+bmo)

Comment 2

2 years ago
Fixing this might just fix bug 1396893 as activity stream is already using find.svg, so if that file is updated / packaged in a way that doesn't need css flipping, we should end up with a consistent icon.
Blocks: 1396893
find.svg is meant for the customizable Find toolbar button. That doesn't seem like the right icon to use here.
Flags: needinfo?(dao+bmo)

Comment 4

2 years ago
aaron, what should the icon be in the address bar?
Flags: needinfo?(abenson)
Reporter

Updated

2 years ago
Flags: needinfo?(shorlander)

Comment 5

2 years ago
The icon should be the new photon search icon that's being used in the new tab in-content search. The search icon currently in the awesombar is old. See the new Design System icon list: http://design.firefox.com/icons/viewer/
Flags: needinfo?(abenson)
Flags: qe-verify?
Flags: qe-verify? → qe-verify+
QA Contact: ovidiu.boca
Assignee

Updated

2 years ago
Assignee: nobody → dharvey
Status: NEW → ASSIGNED
Priority: P4 → P1

Updated

2 years ago
Duplicate of this bug: 1396893
(In reply to Dão Gottwald [::dao] from comment #3)
> find.svg is meant for the customizable Find toolbar button. That doesn't
> seem like the right icon to use here.

We use the same icon for Search and Find. We could add a new icon just for search, but it would be a duplicate.
Flags: needinfo?(shorlander)
Comment hidden (mozreview-request)

Comment 9

2 years ago
mozreview-review
Comment on attachment 8912168 [details]
Bug 1399642 - Use photon search icon in awesomebar.

https://reviewboard.mozilla.org/r/183550/#review188728

Like I said find.svg isn't right here, not visually but semantically. Please rename this file to search-glass.svg.
Attachment #8912168 - Flags: review?(dao+bmo) → review-
Comment hidden (mozreview-request)

Comment 11

2 years ago
mozreview-review
Comment on attachment 8912168 [details]
Bug 1399642 - Use photon search icon in awesomebar.

https://reviewboard.mozilla.org/r/183550/#review188758

It looks like this patch doesn't add search-glass.svg (please use hg move for that).
Attachment #8912168 - Flags: review?(dao+bmo) → review-

Comment 12

2 years ago
Am I looking in the wrong place for if it's `hg move`d or not?

browser/themes/shared/icons/search-glass.svg
Was browser/themes/shared/icons/find.svg

https://reviewboard.mozilla.org/r/183550/diff/2/#6
browser/themes/shared/icons/find.svg
browser/themes/shared/icons/search-glass.svg (moved)
Assignee

Comment 13

2 years ago
I used git mv and cinnabar, but yeh mozreview / hg seems to have detected it as a move https://reviewboard.mozilla.org/r/183550/diff/2/#6

Comment 14

2 years ago
mozreview-review
Comment on attachment 8912168 [details]
Bug 1399642 - Use photon search icon in awesomebar.

https://reviewboard.mozilla.org/r/183550/#review188830

Ugh, reviewboard.

Can you please file a followup on updating the icon in the search bar too?

Thanks!
Attachment #8912168 - Flags: review- → review+

Comment 15

2 years ago
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ade76994700a
Use photon search icon in awesomebar. r=dao
Assignee

Updated

2 years ago
Blocks: 1403359
https://hg.mozilla.org/mozilla-central/rev/ade76994700a
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58

Comment 17

2 years ago
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/fa863ebbef3f831badda8ebb978adf71a86ba5cc
chore(styles): Backport Bug 1399642 - Use photon search icon in awesomebar. r=dao (#3614)
Summary: Search icon in awesomebar is not correct icon / colour → Search icon in awesomebar is not correct icon

Comment 19

2 years ago
The inconsistency isn't totally fixed. The icon for "Find in Preferences" in about:preferences is different from the three other search icons I can see.

(This was originally reported in bug 1396893 which was closed as a duplicate of this bug.)
(In reply to B.J. Herbison from comment #19)
> The inconsistency isn't totally fixed. The icon for "Find in Preferences" in
> about:preferences is different from the three other search icons I can see.
> 
> (This was originally reported in bug 1396893 which was closed as a duplicate
> of this bug.)

I reopened bug 1396893.

Dale, please request beta approval here asap.
Flags: needinfo?(dharvey)
Assignee

Comment 21

2 years ago
Comment on attachment 8912168 [details]
Bug 1399642 - Use photon search icon in awesomebar.

Approval Request Comment
[Feature/Bug causing the regression]: New Photon Visual work
[User impact if declined]: Inconsistent Icons
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Not yet
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: Nope
[Why is the change risky/not risky?]: Mostly an asset change + rename with some minor CSS
[String changes made/needed]:
Flags: needinfo?(dharvey)
Attachment #8912168 - Flags: approval-mozilla-beta?
I verified this issue using Nightly 58.0a1 with Build ID 20171001220301 on Windows 10 x64, Windows 7 x32, Ubuntu 16.04, Mac OS X  10.12.
I will mark this as verified fixed.
Comment on attachment 8912168 [details]
Bug 1399642 - Use photon search icon in awesomebar.

New icons, taking it. Should be in 57b5
Attachment #8912168 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.