Closed Bug 1396914 Opened 2 years ago Closed 2 years ago

PDF may not print all pages

Categories

(Firefox :: PDF Viewer, defect)

56 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 - verified
firefox57 --- fixed

People

(Reporter: yury, Assigned: yury)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

STR:

1. Open http://mozilla.github.io/pdf.js/web/compressed.tracemonkey-pldi-09.pdf
2. Slowly scroll down (using mouse/wheel/touch) to the page 14
3. Print the document

Actual Result:

Some pages are not printed. Console has `pagePage is null`-error.

Expected Result:

All pages are printed.
Regresses https://github.com/mozilla/pdf.js/pull/8746

Fixed by https://github.com/mozilla/pdf.js/pull/8859
Assignee: nobody → ydelendik
Keywords: regression
See Also: → 1389211
Attached patch ff56 patchSplinter Review
Approval Request Comment
[Feature/Bug causing the regression]: bug 1389211
[User impact if declined]: some large documents, when scrolled, cannot be printed
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes, part of the m-c
[Needs manual test from QE? If yes, steps to reproduce]: see comment 0
[List of other uplifts needed for the feature/fix]: no
[Is the change risky?]: minimal, and exists only for certain conditions, e.g. document scrolled and then printed
[Why is the change risky/not risky?]:
[String changes made/needed]: no
Attachment #8904640 - Flags: review?(bdahl)
Attachment #8904640 - Flags: approval-mozilla-beta?
(trunk was fixed by bug 1395787)
Attachment #8904640 - Flags: review?(bdahl) → review+
[Tracking Requested - why for this release]:
Comment on attachment 8904640 [details] [diff] [review]
ff56 patch

Regression from 56, let's uplift the fix for beta 10.
Attachment #8904640 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Keywords: checkin-needed
Whiteboard: [checkin needed for beta/ff56]
https://hg.mozilla.org/releases/mozilla-beta/rev/a09fc917c9b9
Status: NEW → RESOLVED
Closed: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [checkin needed for beta/ff56]
Target Milestone: --- → Firefox 57
Reproduced the initial issue using Firefox 56 beta 9, verified that the issue is fixed using Firefox 56 beta 11 across platforms (Windows 10 64bit, macOS 10.12.6 and Ubuntu 16.04 32bit).
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.