Adding a new Bookmark or Bookmark Folder in the Bookmark Manager and Bookmark Bar yields an empty alert box

RESOLVED DUPLICATE of bug 1397387

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 1397387
10 months ago
8 months ago

People

(Reporter: Daniel Sada, Unassigned)

Tracking

({regression})

57 Branch
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 disabled, firefox57 fixed, firefox58 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
Created attachment 8905152 [details]
bug.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170905220108

Steps to reproduce:

Name 	Firefox
Version 	57.0a1
Build ID 	20170905220108
Update History 	
Update Channel 	nightly
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
OS 	Windows_NT 10.0

Tested on fire
1. Open Firefox
2. Go to Library
3. Open Bookmark Manager
4. Right click bookmarks
5. Click "New Folder..." Item menu



Actual results:

Empty Dialog box


Expected results:

A dialog box to enter the name of the new folder.
(Reporter)

Comment 1

10 months ago
It also repros on the Bookmark Bar. 
(With both creating a folder and a bookmark)
(Reporter)

Updated

10 months ago
Keywords: regression
(Reporter)

Updated

10 months ago
Summary: Adding a new Bookmark Folder in the Bookmark Manager yields an empty alert box → Adding a new Bookmark or Bookmark Folder in the Bookmark Manager and Bookmark Bar yields an empty alert box

Comment 2

10 months ago
I can reproduce:


STR
1. Enable Bookmarks toolbar
2. Right click on the toolbar and Choose "New Bookmark..." and then click on [x] button
3. Again, Right click on the toolbar and Choose "New Bookmark..."

STR
1. Open Library window
2. Right click on the right pane and Choose "New Bookmark..." and then click on [x] button
3. Again, Right click on the right pane and Choose "New Bookmark..."
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

10 months ago
[Tracking Requested - why for this release]:
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
status-firefox57: --- → affected
status-firefox-esr52: --- → unaffected
tracking-firefox57: --- → ?
Component: Untriaged → Bookmarks & History

Comment 4

10 months ago
Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=0da00124af43d44fed96133300ba5e32b0d821a8&tochange=0a4690dfd7b383e2f732210cf8906ce51a5b2433

Regressed by:
0a4690dfd7b3	Mark Banner — Bug 1071513 - Enable async PlacesTransactions for nightly builds. r=mak
Blocks: 1071513
status-firefox56: unaffected → disabled

Updated

10 months ago
Blocks: 1397387

Updated

10 months ago
Blocks: 979280
Alice, have you split your comment 2 into bug 1397387, if so, can you reproduce with just comment 0?

Daniel, I can't reproduce with just your steps. Do you need to do something extra like with comment 2, or am I missing something? Have you also tried in safe mode?
Flags: needinfo?(dshackerc)
Flags: needinfo?(alice0775)

Comment 6

10 months ago
(In reply to Mark Banner (:standard8) from comment #5)
> Alice, have you split your comment 2 into bug 1397387, if so, can you
> reproduce with just comment 0?
>

STR of comment #0 is not enough to reproduce the issue.
So, I made STR of comment#2, then I can reproduce the problem.

> Daniel, I can't reproduce with just your steps. Do you need to do something
> extra like with comment 2, or am I missing something? Have you also tried in
> safe mode?
Flags: needinfo?(alice0775)
(Reporter)

Comment 7

10 months ago
After closing and opening, my build ID updated to:

20170906100107

And I can't repro anymore on this build. So in order to repro effectively we have to do it in the 08 build.
Flags: needinfo?(dshackerc)
(Reporter)

Comment 8

10 months ago
(In reply to Mark Banner (:standard8) from comment #5)
> Alice, have you split your comment 2 into bug 1397387, if so, can you
> reproduce with just comment 0?
> 
> Daniel, I can't reproduce with just your steps. Do you need to do something
> extra like with comment 2, or am I missing something? Have you also tried in
> safe mode?
(In reply to Alice0775 White from comment #6)
> (In reply to Mark Banner (:standard8) from comment #5)
> > Alice, have you split your comment 2 into bug 1397387, if so, can you
> > reproduce with just comment 0?
> >
> 
> STR of comment #0 is not enough to reproduce the issue.
> So, I made STR of comment#2, then I can reproduce the problem.
> 
> > Daniel, I can't reproduce with just your steps. Do you need to do something
> > extra like with comment 2, or am I missing something? Have you also tried in
> > safe mode?


Answered above, sorry for not doing @ reply
My firefox updated build ID
After closing and opening, my build ID updated to:

20170906100107

And I can't repro anymore on this build. So in order to repro effectively we have to do it in the 08 build.
Thanks Daniel, I think it either resolved itself, or it was something caused by a similar issue to what Alice found.

Therefore I'm going to mark this as a duplicate of bug 1397387, where I've already got a patch up and probably almost complete.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
tracking-firefox57: ? → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 1397387
status-firefox57: affected → fixed
status-firefox58: --- → verified
You need to log in before you can comment on or make changes to this bug.