Intermittent toolkit/content/tests/widgets/test_videocontrols_video_direction.html | application ran for longer than allowed maximum time

RESOLVED FIXED in Firefox 57

Status

()

P5
normal
RESOLVED FIXED
a year ago
2 months ago

People

(Reporter: intermittent-bug-filer, Assigned: gbrown)

Tracking

(Blocks: 1 bug, {intermittent-failure})

unspecified
Firefox 58
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox55 unaffected, firefox56 unaffected, firefox57 fixed, firefox58 fixed)

Details

Attachments

(1 attachment)

1 failures in 924 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 1

Platform breakdown:
* android-4-3-armv7-api16: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1397615&startday=2017-09-04&endday=2017-09-10&tree=all
(Assignee)

Comment 2

a year ago
Android Debug mochitest-48 timed out after 90+ minutes. It was not hung.

Screenshot shows "Thanks for choosing Nightly" welcome page, which seems wrong. Also, "Would you like Nightly to remember this login?" doorhanger; that might be a consequence of the last mochitest to run...or not.

Android Debug mochitest-48 is a long-running chunk, normally over 60 minutes, and sometimes 80+ minutes: too close to the 90 minute application max run time for comfort.
Assignee: nobody → gbrown
(Assignee)

Updated

a year ago
Duplicate of this bug: 1397995
(Assignee)

Comment 4

a year ago
 toolkit/mozapps/extensions/test/mochitest/test_bug609794.html | took 3520ms
 toolkit/xre/test/test_fpuhandler.html | took 3875ms
 toolkit/components/passwordmgr/test/mochitest/test_xhr_2.html | took 5049ms
 toolkit/components/windowcreator/test/test_bug499115.html | took 5089ms
 toolkit/content/tests/widgets/test_mousecapture_area.html | took 6183ms
 toolkit/components/windowcreator/test/test_nsFind.html | took 6661ms
 toolkit/content/tests/widgets/test_videocontrols_audio.html | took 7360ms
 toolkit/components/passwordmgr/test/mochitest/test_onsubmit_value_change.html | took 8902ms
 toolkit/components/extensions/test/mochitest/test_ext_generate.html | took 9147ms
 toolkit/components/passwordmgr/test/mochitest/test_basic_form.html | took 9369ms
 toolkit/components/passwordmgr/test/mochitest/test_input_events.html | took 10290ms
 toolkit/components/passwordmgr/test/mochitest/test_bug_776171.html | took 10751ms
 toolkit/components/passwordmgr/test/mochitest/test_basic_form_pwevent.html | took 11014ms
 toolkit/content/tests/widgets/test_bug898940.html | took 11535ms
 toolkit/components/extensions/test/mochitest/test_ext_webrequest_websocket.html | took 11887ms
 toolkit/components/passwordmgr/test/mochitest/test_form_action_2.html | took 12243ms
 toolkit/components/passwordmgr/test/mochitest/test_basic_form_0pw.html | took 12509ms
 toolkit/components/url-classifier/tests/mochitest/test_classify_ping.html | took 12647ms
 toolkit/components/passwordmgr/test/mochitest/test_input_events_for_identical_values.html | took 13276ms
 toolkit/components/prompts/test/test_bug619644.html | took 13547ms
 toolkit/components/windowcreator/test/test_private_window_from_content.html | took 14386ms
 toolkit/content/tests/widgets/test_videocontrols_error.html | took 14924ms
 toolkit/components/extensions/test/mochitest/test_ext_listener_proxies.html | took 15808ms
 toolkit/components/url-classifier/tests/mochitest/test_classifier_match.html | took 15915ms
 toolkit/components/passwordmgr/test/mochitest/test_basic_form_1pw_2.html | took 16363ms
 toolkit/components/extensions/test/mochitest/test_ext_contentscript_css.html | took 16824ms
 toolkit/components/passwordmgr/test/mochitest/test_basic_form_2pw_2.html | took 16932ms
 toolkit/components/passwordmgr/test/mochitest/test_basic_form_3pw_1.html | took 17495ms
 toolkit/mozapps/extensions/test/mochitest/test_bug887098.html | took 17528ms
 uriloader/exthandler/tests/mochitest/test_unsafeBidiChars.xhtml | took 17916ms
 toolkit/components/passwordmgr/test/mochitest/test_passwords_in_type_password.html | took 18823ms
 toolkit/components/extensions/test/mochitest/test_ext_external_messaging.html | took 18919ms
 toolkit/components/url-classifier/tests/mochitest/test_classifier_worker.html | took 18943ms
 toolkit/components/passwordmgr/test/mochitest/test_basic_form_2pw_1.html | took 18946ms
 toolkit/components/passwordmgr/test/mochitest/test_maxlength.html | took 19218ms
 toolkit/components/passwordmgr/test/mochitest/test_form_action_1.html | took 19722ms
 toolkit/components/extensions/test/mochitest/test_ext_webrequest_permission.html | took 19768ms
 toolkit/components/extensions/test/mochitest/test_ext_background_teardown.html | took 19808ms
 toolkit/components/passwordmgr/test/mochitest/test_formless_autofill.html | took 20573ms
 toolkit/components/passwordmgr/test/mochitest/test_recipe_login_fields.html | took 20632ms
 toolkit/components/passwordmgr/test/mochitest/test_basic_form_pwonly.html | took 21551ms
 toolkit/components/url-classifier/tests/mochitest/test_classify_track.html | took 22091ms
 toolkit/components/extensions/test/mochitest/test_ext_runtime_connect.html | took 22680ms
 toolkit/components/extensions/test/mochitest/test_ext_runtime_id.html | took 22767ms
 toolkit/components/extensions/test/mochitest/test_ext_sendmessage_doublereply.html | took 22959ms
 toolkit/components/extensions/test/mochitest/test_ext_contentscript_teardown.html | took 24324ms
 toolkit/components/url-classifier/tests/mochitest/test_classifier.html | took 24794ms
 toolkit/components/passwordmgr/test/mochitest/test_form_action_javascript.html | took 25724ms
 toolkit/components/extensions/test/mochitest/test_ext_sendmessage_reply.html | took 25772ms
 toolkit/components/extensions/test/mochitest/test_ext_sandbox_var.html | took 25856ms
 toolkit/components/extensions/test/mochitest/test_ext_xhr_capabilities.html | took 25857ms
 toolkit/components/passwordmgr/test/mochitest/test_formless_submit.html | took 25878ms
 toolkit/components/windowcreator/test/test_bug293834.html | took 26169ms
 toolkit/components/extensions/test/mochitest/test_ext_background_generated_url.html | took 27131ms
 toolkit/components/extensions/test/mochitest/test_ext_runtime_connect_twoway.html | took 27287ms
 toolkit/components/passwordmgr/test/mochitest/test_basic_form_1pw.html | took 27608ms
 toolkit/components/extensions/test/mochitest/test_ext_window_postMessage.html | took 27649ms
 toolkit/components/extensions/test/mochitest/test_ext_sendmessage_frameId.html | took 28451ms
 toolkit/components/url-classifier/tests/mochitest/test_gethash.html | took 29200ms
 toolkit/components/extensions/test/mochitest/test_ext_storage_tab.html | took 31895ms
 toolkit/components/extensions/test/mochitest/test_ext_unlimitedStorage.html | took 32320ms
 toolkit/components/passwordmgr/test/mochitest/test_autofill_password-only.html | took 33282ms
 toolkit/components/extensions/test/mochitest/test_ext_webrequest_suspend.html | took 34091ms
 toolkit/components/url-classifier/tests/mochitest/test_cachemiss.html | took 34727ms
 toolkit/components/extensions/test/mochitest/test_ext_test.html | took 35146ms
 toolkit/components/passwordmgr/test/mochitest/test_basic_form_html5.html | took 38341ms
 toolkit/content/tests/widgets/test_videocontrols_orientation.html | took 42117ms
 toolkit/content/tests/widgets/test_videocontrols_iframe_fullscreen.html | took 42292ms
 toolkit/components/extensions/test/mochitest/test_ext_cookies.html | took 43615ms
 toolkit/components/extensions/test/mochitest/test_ext_notifications.html | took 44245ms
 toolkit/components/extensions/test/mochitest/test_ext_runtime_disconnect.html | took 45358ms
 toolkit/components/extensions/test/mochitest/test_ext_sendmessage_no_receiver.html | took 47042ms
 toolkit/components/extensions/test/mochitest/test_ext_redirect_jar.html | took 47858ms
 toolkit/components/extensions/test/mochitest/test_ext_background_api_injection.html | took 48403ms
 toolkit/components/extensions/test/mochitest/test_ext_webrequest_frameId.html | took 48647ms
 toolkit/components/extensions/test/mochitest/test_ext_webrequest_background_events.html | took 50343ms
 toolkit/components/extensions/test/mochitest/test_ext_contentscript_permission.html | took 50809ms
 toolkit/components/extensions/test/mochitest/test_ext_unload_frame.html | took 53144ms
 toolkit/components/extensions/test/mochitest/test_ext_runtime_connect2.html | took 54414ms
 toolkit/components/extensions/test/mochitest/test_ext_new_tab_processType.html | took 57757ms
 toolkit/components/extensions/test/mochitest/test_ext_exclude_include_globs.html | took 61619ms
 toolkit/content/tests/widgets/test_videocontrols_video_direction.html | took 64956ms
 toolkit/components/extensions/test/mochitest/test_ext_storage_content.html | took 68070ms
 toolkit/content/tests/widgets/test_videocontrols_audio_direction.html | took 75932ms
 toolkit/components/url-classifier/tests/mochitest/test_bug1254766.html | took 76343ms
 toolkit/components/extensions/test/mochitest/test_ext_webrequest_hsts.html | took 79379ms
 toolkit/components/extensions/test/mochitest/test_ext_webnavigation_filters.html | took 85218ms
 toolkit/components/extensions/test/mochitest/test_ext_subframes_privileges.html | took 90096ms
 toolkit/components/extensions/test/mochitest/test_ext_webrequest_filter.html | took 98485ms
 toolkit/components/extensions/test/mochitest/test_ext_web_accessible_resources.html | took 120448ms
 toolkit/components/passwordmgr/test/mochitest/test_formless_submit_navigation.html | took 122181ms
 toolkit/components/passwordmgr/test/mochitest/test_formless_submit_navigation_negative.html | took 195609ms
 toolkit/components/extensions/test/mochitest/test_ext_webnavigation.html | took 228838ms
 toolkit/components/extensions/test/mochitest/test_ext_webrequest_basic.html | took 234522ms
(Assignee)

Comment 5

a year ago
Created attachment 8910303 [details] [diff] [review]
skip some long-running mochitests on Android Debug

Mochitests run slower on Android Debug than on any other test platform. We run Android Debug mochitests in 48 chunks and each one currently runs for 30 minutes or more. Since some individual tests require much longer to complete than others, some chunks run longer than others. That's a generic problem that we face on all test platforms, but it seems amplified on Android Debug.

Android Debug mochitest-48 is a test chunk with several long-running tests and it usually requires nearly 90 minutes to run; if it takes a little longer, the job fails for exceeding the 90 minute maximum.

I could try adding more chunks, but that doesn't seem appropriate with most chunks completing in less than 45 minutes. Also, if most of the long-running tests remain in the last chunk, more chunks probably won't help.

Instead, I propose skipping the worst offenders: Skip these 9 long-running (run times in the range of 4 to 15+ minutes!) tests on Android Debug only. All of these tests would continue running on Android Opt and all desktop platforms.

The result is that all mochitest chunks run in less than about 60 minutes:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=69bc72c3aad86a8197ae07829b7466fae151452c
Attachment #8910303 - Flags: review?(snorp)
Attachment #8910303 - Flags: review?(snorp) → review+

Comment 6

a year ago
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/60f397f57cd4
Skip some long-running mochitests on Android Debug only; r=snorp
https://hg.mozilla.org/mozilla-central/rev/60f397f57cd4
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox58: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
status-firefox57: --- → affected

Comment 8

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/9c49f9ce76fa
status-firefox57: affected → fixed
Depends on: 1409592
Blocks: 1409592
No longer depends on: 1409592
You need to log in before you can comment on or make changes to this bug.