Closed Bug 1397903 Opened 3 years ago Closed 3 years ago

Pocket "click" lit-up/animated icon is shifted 1px to the right

Categories

(Firefox :: Theme, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1397583

People

(Reporter: dholbert, Unassigned)

Details

(Keywords: regression)

Attachments

(2 files)

STR:
 0. Log in to Pocket.

 1. Turn on the "Compact" density for your toolbar.
  (Right click toolbar, choose "customize", and then click the "Density" menu and choose "Compact")

 2. Visit example.org or some other website.
 3. Click the pocket icon in the URL bar.

ACTUAL RESULTS:
When the colorful verison of the Pocket Icon shows up when you click, it's offset to the right by ~1px (though it's on top of another version of the same icon, so it effectively looks like it just gets "smeared" to be a little fatter).

EXPECTED RESULTS:
Colorful version of Pocket Icon should not be offset to the right of the normal position.


(Note: Step 0 may or may not be necessary, depending on whether the not-logged-in pocket icon triggers a new-tab or just a doorhanger for the sign-up flow. I see each behavior in two different ~fresh profiles locally, and the new-tab behavior makes this bug hard to see because the colorful icon disappears as soon as the new tab opens.)


mozregression range:
Last good revision: 2b0d4df90489db8e1922c28cf3c9fc973ce86d0b
First bad revision: 31c8cec38f4677dd87156c8a0a55290f3fc1a67c
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=2b0d4df90489db8e1922c28cf3c9fc973ce86d0b&tochange=31c8cec38f4677dd87156c8a0a55290f3fc1a67c

--> regression from bug 1388589
The symptoms here are basically the same as bug 1390182 (though that bug was fixed a while back). --> Adding it to "see also".
See Also: → 1390182
Attached video screencast of bug
Flags: needinfo?(adw)
(In reply to Daniel Holbert [:dholbert] from comment #1)
> The symptoms here are basically the same as bug 1390182 (though that bug was
> fixed a while back). --> Adding it to "see also".

Ah, and now I see there's another version of this bug that was filed earlier (and was also marked as "see also").

--> duping.
No longer blocks: 1388589
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
See Also: 1390182
Duplicate of bug: 1397583
Flags: needinfo?(adw)
You need to log in before you can comment on or make changes to this bug.