Regression: favicons missing in Bookmarks toolbar

RESOLVED FIXED in Firefox 57

Status

()

P1
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Mark12547, Assigned: mak)

Tracking

({regression})

57 Branch
Firefox 57
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 fixed)

Details

(Whiteboard: [fxsearch])

Attachments

(2 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170907220212

Steps to reproduce:

Note: Firefox was configured to display Bookmarks Toolbar.


Actual results:

When I start up Firefox, all the favicons in the Bookmarks Toolbar were missing. In fact, I can click on a bookmark in the Bookmarks toolbar to visit the site, the favicon appears in the toolbar for at bookmark, shut down Firefox, start up Firefox, and that favicon is missing again!


Expected results:

When I start up Firefox, the favicons in the Bookmarks Toolbar should be displayed for sites I had visited.

This just started happening in tonight's Nightly, Build ID 20170907220212. This problem did not exist in this morning's Nightly update.

I also ran a regression-gui, specifying to resuse the profile. First run is to customize to display the Bookmarks toolbar, then to add an item to the toolbar (I pasted in https://www.reddit.com/r/firefox/ to the address bar, brought up the page, then dragged the (i) to the toolbar to add this to the toolbar; then I shut down Firefox, then told regression-gui to "retry".)

I am attaching the log and the bisection informations below for the regression run; a success means it is displaying the favicons in the Bookmarks Toolbar when Firefox starts up; a failure means the favicons were missing from the Bookmarks Toolbar.
(Reporter)

Comment 1

a year ago
Bisection Informations:

app_name: firefox
build_date: 2017-09-07 10:36:12.160000
build_file: C:\Users\Mark12547\.mozilla\mozregression\persist\a0be5817a721--autoland--target.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/MBFg7kfaQZOQmk-QfqJq-g/runs/0/artifacts/public%2Fbuild%2Ftarget.zip
changeset: a0be5817a7214701ba799edef2dcda16d29195fc
pushlog_url: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=ebc53301e8df237714c6aac6955078177c4e5ea8&tochange=bd0ce93776feb070b1e48a98200782bc32a20e5a
repo_name: autoland
repo_url: https://hg.mozilla.org/integration/autoland
task_id: MBFg7kfaQZOQmk-QfqJq-g


Last few lines of the Log (full log attached as a test file):

2017-09-07T21:24:44: INFO : Narrowed inbound regression window from [ebc53301, a0be5817] (3 builds) to [acf2ccf3, a0be5817] (2 builds) (~1 steps left)
2017-09-07T21:24:44: DEBUG : Starting merge handling...
2017-09-07T21:24:44: DEBUG : Using url: https://hg.mozilla.org/integration/autoland/json-pushes?changeset=a0be5817a7214701ba799edef2dcda16d29195fc&full=1
2017-09-07T21:24:45: DEBUG : Found commit message:
Bug 1392081 - Reset the Places toolbar view when the toolbar is collapsed. r=Gijs

MozReview-Commit-ID: IFOxCnslZRX

2017-09-07T21:24:45: INFO : The bisection is done.
2017-09-07T21:24:45: INFO : Stopped
(Reporter)

Comment 2

a year ago
Created attachment 8905770 [details]
Regression Log
Component: Untriaged → Bookmarks & History
Keywords: regression
(Assignee)

Comment 3

a year ago
Do you have extensions.legacy.enabled set to true and some legacy extensions?
"First run is to customize to display the Bookmarks toolbar" How?

Could you please provide better steps to reproduce the problem in a clean profile?
Flags: needinfo?(Mark12547)
(Assignee)

Updated

a year ago
Keywords: steps-wanted
(Assignee)

Updated

a year ago
Blocks: 1392081
(Assignee)

Comment 4

a year ago
Fwiw, I'm on the same build and my toolbar works properly, so looks like there is some required additional step to cause the bug.
Summary: REGRESSION! favicons missing in Bookmarks toolbar → Regression: favicons missing in Bookmarks toolbar

Comment 5

a year ago
I can reproduce this when the toolbar is not overflowing, shrinking the window to cause overflow makes the icons appear.
(Assignee)

Comment 6

a year ago
Thanks, that helps.
Assignee: nobody → mak77
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: steps-wanted
Priority: -- → P1
Whiteboard: [fxsearch]
Comment hidden (mozreview-request)

Comment 8

a year ago
mozreview-review
Comment on attachment 8905911 [details]
Bug 1398019 - Favicons missing in Bookmarks toolbar on startup.

https://reviewboard.mozilla.org/r/177706/#review182766

LGTM.
Attachment #8905911 - Flags: review?(past) → review+

Comment 9

a year ago
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/0a49941e45a5
Favicons missing in Bookmarks toolbar on startup. r=past
(Reporter)

Comment 10

a year ago
Some other patch must have landed this morning because I can no longer drag the (i) from the address bar into the Bookmarks toolbar, a change between last night's Nightly and this morning's Nightly. (Probably the patch to improve the experience of dragging tabs to rearrange them without accidentally dragging tabs into new windows.)

Comment 3
> Could you please provide better steps to reproduce the problem in a clean profile?

This morning (without the complication of mozregression-gui), these are the steps I did and reproduced the problem on Build ID 20170908100218:

I used about:profiles in Nightly to delete profile Test_Nightly_New, then I used Nightly to create profile Test_Nightly_New. I then shut down Nightly.

I used a Windows shortcut to launch Nightly using profile Test_Nightly_New. (Yes, I have a shortcut with -p "Test_Nightly_New".)

I navigated to a web page, such as https://bugzilla.mozilla.org/show_bug.cgi?id=1398019

This time I click on the star (Bookmark this page) and in the pop-up dialog specify that the bookmark should be added to the Bookmarks Toolbar. Done.

Observe that the Bookmarks Toolbar now has three entries in it: Most Visited, Get Involved, and 1398019 - Regression: ... and the Bugzilla Favicon is displayed in the Toolbar.

Shut down this Nightly.

Launch Nightly using profile Test_Nightly_New. (On the pop-up, I responded: Don't ask me again. Make Nightly my default browser: NOT NOW.)

Observe that the Favicons in the Bookmarks Toolbar are MISSING. When I click on "1398019 - Regression: ..." on the Bookmark Toolbar, the Bugzilla Favicon reappears in the Toolbar.

Comment 3
> Do you have extensions.legacy.enabled set to true and some legacy extensions?

No. This run I described in this comment is exactly as I ran it this morning, starting with the creation of a brand new profile. No extensions added, no about:config changes, and extensions.legacy.enabled sitting at False.

The problem was first observed by me last night using my regular Nightly profile and bookmarks, which has been legacy-free for about two weeks now and has had extensions.legacy.enabled back to False for that time. And like comment 5 my Bookmarks toolbar all fits within the width of the Firefox window, both for my regular Nightly profile and for the Test_Nightly_New profile that I mentioned in this current comment.

Comment 3
> "First run is to customize to display the Bookmarks toolbar" How?

Sorry, I was describing the steps to run the regression. That's why that paragraph started with "I also ran a regression-gui", and what followed was specific to running mozregression-gui. Would you like me to expand on that?
Flags: needinfo?(Mark12547)

Comment 11

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/0a49941e45a5
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
(Assignee)

Comment 12

a year ago
(In reply to Mark from comment #10)
> Some other patch must have landed this morning because I can no longer drag
> the (i) from the address bar into the Bookmarks toolbar, a change between
> last night's Nightly and this morning's Nightly. (Probably the patch to
> improve the experience of dragging tabs to rearrange them without
> accidentally dragging tabs into new windows.)

What I see is that D&D works but the drop indicator on the bookmarks toolbar is messed up (it appears on the tabs toolbar for me), though so far I'm the only one reproducing the problem. If you see the same please file it, and a regression-range would be really useful.
(Reporter)

Comment 13

a year ago
Comment 12
> What I see is that D&D works but the drop indicator on the bookmarks toolbar is messed up

Since this is unlikely related to Favicons, do we have a "Bug" open for this yet?

And if you are referring to the down-pointing triangle, yes, that is missing for me, too. (I think in my case the drop zone for moving to the Bookmarks Toolbar had shrunk, but it turns out I can still drag to the Bookmarks toolbar ... usually.)
(Reporter)

Comment 14

a year ago
Found it: Bug 1398252
(Reporter)

Comment 15

a year ago
Favicons in Bookmarks Toolbar appear to be fixed in Firefox Nightly 57.0a1 (2017-09-08) (64-bit) Build ID 20170908220146.

Thank you!
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
status-firefox-esr52: --- → unaffected
(Assignee)

Updated

a year ago
Duplicate of this bug: 1398323
You need to log in before you can comment on or make changes to this bug.