Wrong email password makes password manager show error dialog forever

RESOLVED DUPLICATE of bug 121926

Status

SeaMonkey
Passwords & Permissions
--
major
RESOLVED DUPLICATE of bug 121926
16 years ago
13 years ago

People

(Reporter: Jon Fleming, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla 1.0 RC 1 (build ID 2002041711):

When creating a new profile and setting up an email 
account and getting new messages for the first time, I apparently entered the wrong password and 
then checked the "Use Password Manager to Remember this Password" check-box.  A dialog box 
appeared saying that the password was bad.  Picking "OK" dismissed the dialog box and it 
reappeared immediately.  The only thing that I could do was open Task Manager and terminate 
Mozilla.  The problem recurred when I reopened Mozilla, with no possibility of entering the 
correct password.  The only way I could fix it was to delete the profile and rebuild it from 
scratch.

1. Start Mozilla Profile Manager.  Create a new profile.
2. Open mail.  You will be 
prompted to create an account.
3. Specify a valid email account.
4. When the password dialog 
box appears, pick "Cancel".
5.  Open mail & news account settings.  Under "Servers", check the 
"Leave mail on server", "Delete messages on server when deleted from inbox" and "empty trash on 
exit" check boxes.
5.  Pick OK.

Comment 1

16 years ago
By adding a few steps I can reproduce with Win XP branch 2002042306

1. Start Mozilla Profile Manager.  Create a new profile.
2. Open mail.  You will be 
prompted to create an account.
3. Specify a valid email account.
4. When the password dialog 
box appears, pick "Cancel".
5.  Open mail & news account settings.  Under "Servers", check the 
"Leave mail on server", "Delete messages on server when deleted from inbox" and
"empty trash on 
exit" check boxes.
6.  Pick OK.
7. Click get messages
8. Password dialog comes up, enter a bad password
9. Click remember this in password manager
10. Error dialog continues to come up, you are never asked to re-enter a new
password

Side note: if you close the browser and reopen mail, it freezes and you are
forced to kill the browser
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 121926 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.