Google Cloud Platform shows blank page due to lack of Long Task implementation

RESOLVED FIXED

Status

P3
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: ilja, Unassigned)

Tracking

(Depends on: 1 bug, {regression})

unspecified
x86_64
Windows 10
regression

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57+ fixed)

Details

(URL)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170909100226

Steps to reproduce:

Browse to https://console.cloud.google.com/ and login. Blank page is returned. Same issue on a clean install, two different clients. Works fine in beta, stable and other browsers.
Seems to have occurred after 2017-09-07 build.
Windows 10 Enterprise (and Professional, on another machine), both 1703 15063.540.


Actual results:

Blank page is displayed.


Expected results:

The page is displayed correctly.
(Reporter)

Updated

a year ago
Component: Untriaged → General
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Has Regression Range: --- → no
Has STR: --- → yes
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
status-firefox57: --- → affected
status-firefox-esr52: --- → unaffected
Keywords: regression, regressionwindow-wanted

Comment 1

a year ago
setting dom.enable_performance_observe = false should fix.

This is not a recent regression in the nightly channel.
This is reproduced since Nightly49 (Bug 1271487).

And the prefs becomes true by default in next Beta57 (Bug 1386021).
So, it will be red alarm for next beta57.
Blocks: 1386021, 1271487
Status: UNCONFIRMED → NEW
Component: General → DOM
Ever confirmed: true
Keywords: regressionwindow-wanted
Product: Firefox → Core

Comment 2

a year ago
[Tracking Requested - why for this release]: Google Cloud Platform is broken in Nightly57 and will be broken in next beta 57 cycle as well.
tracking-firefox57: --- → ?
The site uses PerformanceObserver for observing long task [1], but we don't still support long task (bug 1348405).  Also, PerformanceObserver.observe() throws when no valid entry type is passed to the method.  Unfortunately when I implement PerformanceObserver long task api did not exist.  I think we can handle 'longtask' as a valid entry type, but the site should also work fine without long task support.

[1] https://w3c.github.io/longtasks/
See Also: → bug 1348405
I think this is a sort of web compact issue.  WebKit does not handle 'longtask' as a valid entry type either [1], so the Google Cloud Platform will not work on WebKit either. I think the site should work even though PerformanceObserver.observe() throws an exception. :overholt, what should we do for such cases? 

FWIW here is a try that handles 'longtask' as a valid entry, it makes the Google Cloud Platform work.

Also note that there are some discussions about APIs to get information what entry types are supported by UA [2][3].

https://treeherder.mozilla.org/#/jobs?repo=try&revision=8ff2d59a74e2f16d90133993f580c434b08c8a02

[1] https://trac.webkit.org/browser/webkit/trunk/Source/WebCore/page/PerformanceEntry.cpp?rev=211406#L53
[2] https://github.com/w3c/performance-timeline/issues/77
[3] https://github.com/w3c/performance-timeline/issues/64
Flags: needinfo?(overholt)
Tracking as upcoming webcompat regression in 57 beta.
tracking-firefox57: ? → +

Comment 7

a year ago
Opened spec issue to track this: https://github.com/w3c/performance-timeline/issues/87 -- would appreciate any feedback.
Per https://github.com/webcompat/web-bugs/issues/9716#issuecomment-328915490 this will be fixed on google cloud platform within a week.
I experience the same issue in Nightly.
(In reply to Hiroyuki Ikezoe (:hiro) from comment #4)
> I think this is a sort of web compact issue.  WebKit does not handle
> 'longtask' as a valid entry type either [1], so the Google Cloud Platform
> will not work on WebKit either. I think the site should work even though
> PerformanceObserver.observe() throws an exception. :overholt, what should we
> do for such cases? 

The spec discussion is probably the best place for this and I'm happy to hear Google Cloud Platform will work without a potentially ugly fix here.
Component: DOM → Desktop
Depends on: 1348405
Flags: needinfo?(overholt)
Priority: -- → P3
Product: Core → Tech Evangelism
Summary: Blank page on Google Cloud Platform → Google Cloud Platform shows blank page due to lack of Long Task implementation
Version: 57 Branch → unspecified

Comment 11

a year ago
it's fixed.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME

Updated

a year ago
status-firefox57: affected → fixed
Resolution: WORKSFORME → FIXED
You need to log in before you can comment on or make changes to this bug.