Closed Bug 1398635 Opened 2 years ago Closed 2 years ago

Crash in FileClose

Categories

(Core :: DOM: File, defect, critical)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- fixed

People

(Reporter: marcia, Assigned: baku)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-aac59f8b-984f-41bb-b4dd-173860170910.
=============================================================

Seen while looking at crash stats - crashes started using 20170908220146: http://bit.ly/2vOemII

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d8e238b811d3dc74515065ae8cab6c74baf0295f&tochange=ea7b55d65d76214f97aaae502d65cb26fc6f5659

Possible regression from Bug 1397627? ni on baku
Flags: needinfo?(amarchesini)
Attached patch crash.patchSplinter Review
This is because we keep mRemoteStream and mAsyncRemoteStream and we cancel it in different threads. mRemoteStream should be null when mAsyncRemoteStream is created.
Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)
Attachment #8906488 - Flags: review?(bugs)
Attachment #8906488 - Flags: review?(bugs) → review+
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4edf631edd32
IPCBlobInputStream must release the remoteStream when the pipe inputStream wraps it in order to avoid double close(), r=smaug
Crash Signature: [@ FileClose] → [@ FileClose] [@ arena_dalloc | _PR_Putfd | pt_Close] [@ PR_Close | nsFileStreamBase::Close] [@ <name omitted> | non-virtual thunk to mozilla::net::nsInputStreamTransport::Close]
https://hg.mozilla.org/mozilla-central/rev/4edf631edd32
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Duplicate of this bug: 1399058
Duplicate of this bug: 1399254
Duplicate of this bug: 1398487
--> adding crash signature from dupe bug 1398487.
Crash Signature: [@ FileClose] [@ arena_dalloc | _PR_Putfd | pt_Close] [@ PR_Close | nsFileStreamBase::Close] [@ <name omitted> | non-virtual thunk to mozilla::net::nsInputStreamTransport::Close] → [@ FileClose] [@ arena_dalloc | _PR_Putfd | pt_Close] [@ PR_Close | nsFileStreamBase::Close] [@ <name omitted> | non-virtual thunk to mozilla::net::nsInputStreamTransport::Close] [@ free.cold.32 | _PR_Putfd | pt_Close.cold.7 ]
You need to log in before you can comment on or make changes to this bug.