Closed Bug 1398696 Opened 2 years ago Closed 2 years ago

[Windows 7] The title bar color doesn't match the tab bar color in Light/Dark theme on Aero Basic

Categories

(Firefox :: Theme, defect, P1)

57 Branch
Unspecified
Windows 7
defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 --- verified
firefox58 --- verified

People

(Reporter: Ovidiu, Assigned: johannh)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(5 files)

Maybe there is a duplicate after this issue. 

[Affected versions]:

- Nightly 57.0a1(2017-09-10)
 
[Affected platforms]:

- Windows 7, Windows 10, Mac OS with "Light" theme.
 
[Steps to reproduce]:

1. Enabled the Title Bar
2. Change the browser theme (select"Light" or "Dark" ) 


Actual result:

The title bar color doesn't match the tab bar color. 

Expected result:

The title bar should match the tab bar color(see the behavior from the "Default" theme)

Note: We also saw this on Mac with the "Light" theme. For "Dark" theme there is bug 1392219.
Whiteboard: [photon-visual][triage]
Flags: qe-verify+
Priority: -- → P4
QA Contact: ovidiu.boca
Whiteboard: [photon-visual][triage] → [reserve-photon-visual]
This will be fixed in bug 1399498.
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Depends on: 1399498
OS: Unspecified → Windows 7
Priority: P4 → P1
Summary: The title bar color doesn't match the tab bar color. → [Windows 7] The title bar color doesn't match the tab bar color.
Iteration: --- → 57.3 - Sep 19
Marking as resolved since Bug 1399498 has been resolved (see Comment #3 above).
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
See Also: → 1399498
I tested this on Windows 7 x64 with FF Nightly 58.0a1(2017-10-03) and I found an issue. Enabled the title bar and then set the Windows theme on "Windows 7 Basic" or "Windows Classic", a white line appears between the title bar and the tab bar.(for a better observation please use browser's light or dark theme).
Note: If I use Aero Theme(Windows 7) this issue is not reproducible. 
Please see the attached file with the actual result.
I also have another observation: Giving the fact that on Aero theme (Windows 7) the title bar and the tab bar have a unique and uniform color the other Windows theme like "Windows 7 Basic" should have the same unique and uniform color between title bar and tab bar. 

Please see the attached file, where I did a comparison between Aero theme and Windows 7 Basic theme.
Reopening because we should fix comment 6.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Iteration: 57.3 - Sep 19 → ---
Summary: [Windows 7] The title bar color doesn't match the tab bar color. → [Windows 7] The title bar color doesn't match the tab bar color in Light/Dark theme on Aero Basic
Comment on attachment 8919256 [details]
Bug 1398696 - Override the window background to Windows Aero Basic colors for Light/Dark theme on Windows 7.

https://reviewboard.mozilla.org/r/190158/#review195416
Attachment #8919256 - Flags: review?(dao+bmo) → review+
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/de4a2586cbfd
Override the window background to Windows Aero Basic colors for Light/Dark theme on Windows 7. r=dao
https://hg.mozilla.org/mozilla-central/rev/de4a2586cbfd
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Comment on attachment 8919256 [details]
Bug 1398696 - Override the window background to Windows Aero Basic colors for Light/Dark theme on Windows 7.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1399498
[User impact if declined]: See attachment 8915085 [details]. Users on Windows 7 Aero Basic have a plain white or dark window background, which looks bad and makes it impossible to see toolbar buttons.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Not yet
[Needs manual test from QE? If yes, steps to reproduce]: Not really.
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: It's a small CSS only patch that sets a background color. Even if something were wrong with that color, it's guaranteed to be limited to Windows 7 Aero Basic and light/dark theme by the surrounding media queries.
[String changes made/needed]: None
Attachment #8919256 - Flags: approval-mozilla-beta?
Tested on Windows 7 x64 with FF Nightly 58.0a1(2017-10-18)

With "Windows 7 Basic" theme everything works as expected, but with "Windows Classic" theme the issue is still there.
Flags: needinfo?(jhofmann)
(In reply to ovidiu boca[:Ovidiu] from comment #13)
> Tested on Windows 7 x64 with FF Nightly 58.0a1(2017-10-18)
> 
> With "Windows 7 Basic" theme everything works as expected, but with "Windows
> Classic" theme the issue is still there.

You mean comment 6? I can't see a white line there, can you point it out in the screenshot? In any case, please file a different bug for that.
Flags: needinfo?(jhofmann)
In comment 6 the issue was observed on both: "Windows 7 Basic" theme and "Windows Classic" theme. I tested with "Windows 7 Basic" theme and everything works, but if I try with "Windows Classic" theme, the issue is still there, please see the actual result: https://imgur.com/a/fyHRk
Again, that looks fine to me, can you please highlight or describe the issue somehow?
The title bar and the tab bar have a unique and uniform color on "Aero" theme but are not the same with "Windows Classic" theme. I made a comparison here: https://imgur.com/a/1t1DW
That is intended. :)
Thanks for clearing this out :).
Comment on attachment 8919256 [details]
Bug 1398696 - Override the window background to Windows Aero Basic colors for Light/Dark theme on Windows 7.

severe regression, low risk fix, beta57+
Attachment #8919256 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I verified this on Windows 7 with FF Nightly 58.0a1(2017-10-18) and I can't reproduce the initial issue, based on this and on comment 18 this bug is verified fixed.
I have verified this issue on Windows 7 with Firefox Beta 57.0b10. The issue is verified fixed based on comment #18.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Depends on: 1494981
You need to log in before you can comment on or make changes to this bug.