Closed Bug 1399101 Opened 2 years ago Closed 2 years ago

new tab burst animation sometimes not drawn

Categories

(Firefox :: Tabbed Browser, defect)

57 Branch
Unspecified
Windows 10
defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- fix-optional

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression)

+++ This bug was initially created as a clone of Bug #1398442 +++

After landing Bug 1380150, new tab burst animation sometimes not drawn


Reproducible: Sometimes
Steps To Reproduce:
1. Open http://www.getginger.jp/  (not need allowing flash plugin)
2. Optionally Ctrl+F5

Actual Results:
Sometimes, No tab burst rendered
Whiteboard: [photon-animation] → [photon-animation] [triage]
See Also: → 1399458
(In reply to Alice0775 White from comment #0)
> After landing Bug 1380150, new tab burst animation sometimes not drawn
> 
> Reproducible: Sometimes
> Steps To Reproduce:
> 1. Open http://www.getginger.jp/  (not need allowing flash plugin)
> 2. Optionally Ctrl+F5
> 
> Actual Results:
> Sometimes, No tab burst rendered

Haven't been able to repro this.
I haven't been able to reproduce this either. Without any more reliable steps to reproduce we will have to close this bug as invalid.
Just open the URL, no extra steps is needed. 

I can reproduced on Windows10 and Linux MINT.
Duplicate of this bug: 1399458
Just wanted to let you know that I tested with macOS 10.11 and for both links above the animation works fine for me.
Component: General → Tabbed Browser
Flags: qe-verify?
Priority: -- → P4
Whiteboard: [photon-animation] [triage] → [reserve-photon-animation]
Based on new priority setting.
I reproduced this issue on Firefox 57.0b5 on Mac OS X 10.11 and Windows 8.1 x64, for both links above the animation not works for me (http://www.getginger.jp/ and http://edition.cnn.com/)
Tried it again, and it became complicated:
First open on Nightly (58) the burst on both was working fine
First open on DevEdition (57) the burst on CNN was not firing, but it did fire on GetGinger
Second load on Nightly both stopped and so did the burst for all other tabs now (I guess until I restart).
Reloading on DevEdition doesn't change the situation.

=> CNN is failing (almost) constantly for me in 57 and 58

=> I can't tell why the animation failed for all tabs in Nightly after reloading the two tabs; even after restarting the browser and loading both tabs (CNN animation failed, GetGinger worked) the animation worked reloading CNN and other tabs didn't change this
We're not showing the burst on these sites because when the load finishes the last load is not top-level nor does it finish with a success code (it finishes with 2152398850 which according to http://searchfox.org/mozilla-central/rev/dca019c94bf3a840ed7ff50261483410cfece24f/servo/components/style/gecko/generated/structs.rs#9203 is NS_BINDING_ABORTED).

It appears that the top-level load finishes too fast for us to show the burst and the subsequent load that we are seeing when the progress indicator moves left and right is the result of some non-top-level content that is loading and later aborted (maybe due to a timeout)?

I'm not sure what we can do here for these pages. The code in question is at http://searchfox.org/mozilla-central/rev/dca019c94bf3a840ed7ff50261483410cfece24f/browser/base/content/tabbrowser.xml#776-781
Should we just resolve wontfix? Doesn't seem all that important/prevalent, and maybe even arguably correct if we normally throttle the burst for fast-finishing toplevel loads anyway.
Flags: needinfo?(jaws)
Yeah, that sounds right to me.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jaws)
Resolution: --- → WONTFIX
Priority: P4 → --
Whiteboard: [reserve-photon-animation]
You need to log in before you can comment on or make changes to this bug.