Closed Bug 1399440 Opened 2 years ago Closed 2 years ago

Funsize submits jobs to Treeherder using deprecated revision_hash taskcluster route

Categories

(Release Engineering :: Release Automation: Other, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: emorley, Assigned: sfraser)

References

Details

The Treeherder revision_hash concept has been deprecated for a while, and we're hoping to remove it soon in bug 1257602 - however looking at the New Relic stats I see funsize jobs that are using a revision_hash instead of a revision.

The revision hash is being generated here:
https://github.com/mozilla-releng/funsize/blob/e091471ffca545c0639f7f60cd1be3427f6969b9/funsize/worker.py#L589-L594

And ends up in the task template here:
https://github.com/mozilla-releng/funsize/blob/96d4d90350a8a1ee378f1b0dddfcd45acd4bff53/funsize/tasks/funsize.yml#L36-L37

I'm presuming the task should be switched to using the v2 route (and use `revision` not `revision` hash in the route name), something like here:
https://github.com/mozilla/gecko-dev/blob/e0340aa82f7431c6906857865d064d6bcf3ed187/.taskcluster.yml#L43

I don't suppose somebody could take a look? :-)
Duplicate of this bug: 1399438
This should happen as part of migrating the funsize tasks into taskcluster graphs (bug 1342392).

We're hoping to land that this week.
Depends on: 1342392
Oh handy! Thank you :-)
The new partials tasks, such as https://tools.taskcluster.net/groups/UIlPR-IpSgGjeBrbv2vQPQ/tasks/ISSxdBsTQXiqFDw4VfS6fg/details  appear to be doing things the more up-to-date way. If you're happy that there's nothing needs to be modified with the new style, I'll close the bug.
Flags: needinfo?(emorley)
Assignee: nobody → sfraser
Yeah the new tasks are great, so resolve this once the last of the old jobs stop running (on oak) :-)
Flags: needinfo?(emorley)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
The oak repo is still submitting old style jobs as recently as an hour ago. We can't proceed with bug 1257602 until no jobs at all are being submitted using revision_hash, so leaving this open for now.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Oak has been merged with m-c, and I've not seen any old-style funsize jobs since the 22nd, so I'll resolve this bug
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Many thanks :-)
You need to log in before you can comment on or make changes to this bug.