Closed Bug 1399948 Opened 3 years ago Closed 3 years ago

Implement the photon styles for the inspector breadcrumbs

Categories

(DevTools :: Inspector, enhancement, P3)

enhancement

Tracking

(firefox57 wontfix, firefox58 fixed)

RESOLVED FIXED
Firefox 58
Tracking Status
firefox57 --- wontfix
firefox58 --- fixed

People

(Reporter: gl, Assigned: hobindar)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

Update the inspector breadcrumbs to look like the photon mockups.
Assignee: gl → nobody
Status: ASSIGNED → NEW
Assignee: nobody → darrenhobin
Comment on attachment 8911224 [details]
Bug 1399948 - Part 1: Refactor breadcrumb css into separate file.

https://reviewboard.mozilla.org/r/182714/#review188148
Attachment #8911224 - Flags: review?(gl) → review+
Keywords: leave-open
Pushed by gabriel.luong@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/64a52ab3bab3
Part 1: Refactor breadcrumb css into separate file. r=gl
Comment on attachment 8911436 [details]
Bug 1399948 - Part 2: Implement photon styles for breadcrumbs.

https://reviewboard.mozilla.org/r/182904/#review188156

Clearing the review on this since this requires more work.
Attachment #8911436 - Flags: review?(gl)
Attachment #8911224 - Attachment is obsolete: true
Attachment #8911436 - Flags: review?(gl) → review?(bgrinstead)
Passing this review to bgrins since I am swamped for reviews. This bug is about implementing the photon styles for the breadcrumbs seen here - https://docs.google.com/document/d/1AJ7oHC7akXJiliheHjhFc4fTonaN31Eo_P2M8gssL8s/edit. We saw that the firebug breadcrumbs basically looked similar to what we were aiming for so. So, the task was to un-prefix the firebug theme breadcrumbs and remove the existing styles for the light/dark theme breadcrumbs.
Comment on attachment 8911436 [details]
Bug 1399948 - Part 2: Implement photon styles for breadcrumbs.

https://reviewboard.mozilla.org/r/182904/#review190634

This is great, thanks!
Attachment #8911436 - Flags: review?(bgrinstead) → review+
Keywords: leave-open
Status: NEW → ASSIGNED
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/b8c11514db36
Part 2: Implement photon styles for breadcrumbs. r=bgrins
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/b8c11514db36
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Depends on: 1428917
Product: Firefox → DevTools
No longer depends on: 1428917
Regressions: 1428917
You need to log in before you can comment on or make changes to this bug.