Closed Bug 1428917 Opened 2 years ago Closed 3 months ago

Inspector breadcrumbs divider has wrong direction, margin and padding in RTL locales

Categories

(DevTools :: Inspector, defect, P2)

defect

Tracking

(firefox-esr52 unaffected, firefox-esr60 wontfix, firefox-esr68 fixed, firefox62 wontfix, firefox63 wontfix, firefox64 wontfix, firefox68 wontfix, firefox69 fixed, firefox70 verified)

VERIFIED FIXED
Firefox 70
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- wontfix
firefox-esr68 --- fixed
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox68 --- wontfix
firefox69 --- fixed
firefox70 --- verified

People

(Reporter: magicp.jp, Assigned: itiel_yn8)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image breadcrumbs-in-rtl.png
Steps to reproduce:
1. Launch Nightly in RTL locales
2. Open Inspector

Actual results:
Inspector breadcrumbs divider has wrong direction, margin and padding in RTL locales.

Expected results
Set correct direction, margin and padding in RTL locales.
Priority: -- → P2
Duplicate of this bug: 1457725
Product: Firefox → DevTools

Since the 2 code panels above are LTR and in english characters only, it doesn't make sense to make the bottom part RTL, so remove RTL support altogether and force LTR on html-arrowscrollbox-inner.

Assignee: nobody → itiel_yn8
Status: NEW → ASSIGNED
Pushed by gluong@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c7020788e8b6
Remove broken RTL support for inspector breadcrumbs in RTL locales r=gl
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Status: RESOLVED → VERIFIED

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Feel free to nominate this for Beta & ESR68 approval if you want.

Comment on attachment 9084161 [details]
Bug 1428917 - Remove broken RTL support for inspector breadcrumbs in RTL locales

Beta/Release Uplift Approval Request

  • User impact if declined: Broken inspector breadcrumbs for RTL users
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce: ---
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simple CSS-only changes
  • String changes made/needed: None

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: A (relatively) long standing issue with breadcrumbs for RTL users
  • User impact if declined: Broken inspector breadcrumbs for RTL users
  • Fix Landed on Version: 70
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simple CSS-only changes, tested and verified on Nightly with no apparent regressions as now the RTL experience is the same as LTR
  • String or UUID changes made by this patch: None
Flags: needinfo?(itiel_yn8)
Attachment #9084161 - Flags: approval-mozilla-esr68?
Attachment #9084161 - Flags: approval-mozilla-beta?

Comment on attachment 9084161 [details]
Bug 1428917 - Remove broken RTL support for inspector breadcrumbs in RTL locales

Minor CSS fix to improve RTL support. Approved for 69.0b14 and 68.1esr.

Attachment #9084161 - Flags: approval-mozilla-esr68?
Attachment #9084161 - Flags: approval-mozilla-esr68+
Attachment #9084161 - Flags: approval-mozilla-beta?
Attachment #9084161 - Flags: approval-mozilla-beta+
Depends on: 1574520
No longer depends on: 1574520
Regressed by: 1574520
No longer regressed by: 1574520
Regressions: 1574520
You need to log in before you can comment on or make changes to this bug.