Closed Bug 1400175 Opened 4 years ago Closed 4 years ago

plugin-container crashes when linked with BIND_NOW

Categories

(Core :: Widget: Gtk, defect)

56 Branch
All
Linux
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- fixed

People

(Reporter: heftig, Assigned: heftig)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached patch plugin-crash.diff (obsolete) — Splinter Review
libxul.so requires the symbol gdk_screen_get_monitor_workarea but this symbol is not available in gtk2 and mozgtk does not provide a stub.

For the official builds, this is not a problem as the code using this function never gets called so the linker never looks it up.

Our (Arch Linux) builds have -z now in our LD flags, so the linker resolves all symbols at load time. The plugin-container crashes as it cannot bind gdk_screen_get_monitor_workarea.

The attached patch solves the problem by having mozgtk2 provide a stub. It also replaces the call when building against GTK2, but that's not needed (it should be sane but I didn't test a cairo-gtk2 build, anyway) so you can ignore that hunk.
Blocks: 1350643
Attachment #8908517 - Attachment is obsolete: true
Comment on attachment 8908585 [details]
Bug 1400175 - Stub gdk_screen_get_monitor_workarea in mozgtk2;

https://reviewboard.mozilla.org/r/180248/#review185846

Thank you!
Attachment #8908585 - Flags: review?(karlt) → review+
Pushed by ktomlinson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e46b61728739
Stub gdk_screen_get_monitor_workarea in mozgtk2; r=karlt
https://hg.mozilla.org/mozilla-central/rev/e46b61728739
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Assignee: nobody → jan.steffens
Depends on: 1405590
Duplicate of this bug: 1405590
Blocks: 1427520
Blocks: 1435965
You need to log in before you can comment on or make changes to this bug.