plugin-container crashes when linked with BIND_NOW, again

RESOLVED FIXED in Firefox 59

Status

()

--
major
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: heftig, Assigned: heftig)

Tracking

Trunk
mozilla59
All
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(1 attachment)

Stubs were added to mozgtk.c in bug 1421974 but sorted into the wrong section: gtk_widget_get_preferred_width and _height are not available in gtk2, crashing the plugin-container when it is linked with -z now.

This is basically bug 1400175, again.
(Assignee)

Updated

a year ago
Blocks: 1421974
Depends on: 1400175
Comment hidden (mozreview-request)

Comment 2

a year ago
mozreview-review
Comment on attachment 8939286 [details]
Bug 1427520 - Stub gtk_widget_get_preferred_width/height in mozgtk2;

https://reviewboard.mozilla.org/r/209722/#review215304

Thank you, again.
Attachment #8939286 - Flags: review?(karlt) → review+

Comment 3

a year ago
Pushed by ktomlinson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/355d6145c397
Stub gtk_widget_get_preferred_width/height in mozgtk2; r=karlt
(Assignee)

Updated

a year ago
Assignee: nobody → jan.steffens
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 4

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/355d6145c397
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox59: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
(Assignee)

Updated

a year ago
Blocks: 1435965
You need to log in before you can comment on or make changes to this bug.