Closed Bug 1400337 Opened 2 years ago Closed 2 years ago

throbber should have two states, gray for connecting and blue for transferring data

Categories

(Firefox :: Theme, defect, P1)

x86_64
Windows 10
defect

Tracking

()

RESOLVED FIXED
Firefox 57
Iteration:
57.3 - Sep 19
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- fixed

People

(Reporter: asa, Assigned: Gijs)

References

Details

(Keywords: regression, Whiteboard: [reserve-photon-animation])

Attachments

(1 file)

For several days I've only seen the gray throbber. It used to have two states, gray for connecting and blue for transferring data. Now it only shows gray. Tested Windows nightly builds on Win 10.
Mozregression says that bug 1380150 broke this.
Blocks: 1380150
Keywords: regression
Whiteboard: [photon-animation]
Whiteboard: [photon-animation] → [photon-animation] [triage]
The issue is that the progress change listener never seems to get passed either request or webprogress objects, whatever its arguments/contracts might be pretending. As a result, we now no longer ever set the 'progress' flag:

https://dxr.mozilla.org/mozilla-central/rev/6be5c7d30d2def62a762ac187252eba626b23a92/browser/base/content/tabbrowser.xml#672-673

I don't really have a great idea for a fix off-hand. I'll keep looking for a bit.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: qe-verify?
Priority: -- → P1
Whiteboard: [photon-animation] [triage] → [reserve-photon-animation]
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/8eb9099d21dd
only set 'progress' attribute if 'busy' is already set, r=jaws
https://hg.mozilla.org/mozilla-central/rev/8eb9099d21dd
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Iteration: --- → 57.3 - Sep 19
You need to log in before you can comment on or make changes to this bug.