Closed Bug 1400528 Opened 3 years ago Closed 3 years ago

Intermittent dom/events/test/test_bug574663.html | Normal scrolling should scroll - got 15, expected 18

Categories

(Core :: DOM: Events, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox57 --- fixed
firefox58 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: florian)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed:timing])

Attachments

(1 file)

Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=131442488&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/VaSEFLgfRP6tQe0yuFHfbw/runs/0/artifacts/public/logs/live_backing.log

02:23:42     INFO - TEST-START | dom/events/test/test_bug574663.html
02:23:42     INFO - GECKO(1786) | [Child 1788, Main Thread] WARNING: stylo: ServoStyleSets cannot respond to document state changes yet (only matters for chrome documents). See bug 1290285.: file /builds/worker/workspace/build/src/layout/base/PresShell.cpp, line 4297
02:23:42     INFO - GECKO(1786) | ++DOMWINDOW == 24 (0x122b86800) [pid = 1788] [serial = 153] [outer = 0x124094800]
02:23:42     INFO - GECKO(1786) | [Child 1788, Main Thread] WARNING: stylo: Web Components not supported yet: file /builds/worker/workspace/build/src/dom/base/nsDocument.cpp, line 6412
02:23:42     INFO - GECKO(1786) | [Child 1788, Main Thread] WARNING: stylo: Web Components not supported yet: file /builds/worker/workspace/build/src/dom/base/nsDocument.cpp, line 6412
02:23:42     INFO - GECKO(1786) | [Child 1788, Main Thread] WARNING: Unable to find interface object on global: file /builds/worker/workspace/build/src/dom/base/nsDOMClassInfo.cpp, line 1773
02:23:42     INFO - GECKO(1786) | [Child 1788, Main Thread] WARNING: stylo: ServoStyleSets cannot respond to document state changes yet (only matters for chrome documents). See bug 1290285.: file /builds/worker/workspace/build/src/layout/base/PresShell.cpp, line 4297
02:23:42     INFO - GECKO(1786) | ++DOCSHELL 0x12698d800 == 5 [pid = 1788] [id = {1215d6d3-1f08-b949-9e8a-a03f494d01c1}]
02:23:42     INFO - GECKO(1786) | ++DOMWINDOW == 25 (0x126990000) [pid = 1788] [serial = 154] [outer = 0x0]
02:23:42     INFO - GECKO(1786) | ++DOCSHELL 0x11941e800 == 4 [pid = 1786] [id = {93513890-16fc-2543-b556-3cb679811ace}]
02:23:42     INFO - GECKO(1786) | ++DOMWINDOW == 13 (0x119420000) [pid = 1786] [serial = 27] [outer = 0x0]
02:23:42     INFO - GECKO(1786) | ++DOMWINDOW == 14 (0x119423800) [pid = 1786] [serial = 28] [outer = 0x119420000]
02:23:42     INFO - GECKO(1786) | ++DOCSHELL 0x11952f000 == 5 [pid = 1786] [id = {49eff652-f837-5447-8e51-1f3652f53dca}]
02:23:42     INFO - GECKO(1786) | ++DOMWINDOW == 15 (0x11952f800) [pid = 1786] [serial = 29] [outer = 0x0]
02:23:42     INFO - GECKO(1786) | ++DOCSHELL 0x11bd39000 == 6 [pid = 1786] [id = {c752b255-884f-9742-99c2-0a9576de8d24}]
02:23:42     INFO - GECKO(1786) | ++DOMWINDOW == 16 (0x11bd3e800) [pid = 1786] [serial = 30] [outer = 0x0]
02:23:42     INFO - GECKO(1786) | ++DOMWINDOW == 17 (0x11be61000) [pid = 1786] [serial = 31] [outer = 0x11bd3e800]
02:23:42     INFO - GECKO(1786) | [Parent 1786, Main Thread] WARNING: [nsFrameLoader] ReallyStartLoadingInternal tried but couldn't show remote browser.
02:23:42     INFO - GECKO(1786) | : file /builds/worker/workspace/build/src/dom/base/nsFrameLoader.cpp, line 895
02:23:42     INFO - GECKO(1786) | ++DOMWINDOW == 18 (0x11c2bc000) [pid = 1786] [serial = 32] [outer = 0x11952f800]
02:23:42     INFO - GECKO(1786) | --DOCSHELL 0x12690c000 == 4 [pid = 1788] [id = {8ffe49c7-73fb-d14f-83c9-f14b9a9af1a4}]
02:23:42     INFO - GECKO(1786) | [Child 1788, Main Thread] WARNING: stylo: ServoStyleSets cannot respond to document state changes yet (only matters for chrome documents). See bug 1290285.: file /builds/worker/workspace/build/src/layout/base/PresShell.cpp, line 4297
02:23:42     INFO - GECKO(1786) | [Child 1788, Main Thread] WARNING: stylo: ServoStyleSets cannot respond to document state changes yet (only matters for chrome documents). See bug 1290285.: file /builds/worker/workspace/build/src/layout/base/PresShell.cpp, line 4297
02:23:42     INFO - GECKO(1786) | ++DOMWINDOW == 26 (0x122607000) [pid = 1788] [serial = 155] [outer = 0x126990000]
02:23:42     INFO - GECKO(1786) | ++DOMWINDOW == 27 (0x12698a800) [pid = 1788] [serial = 156] [outer = 0x126990000]
02:23:42     INFO - GECKO(1786) | [Child 1788, Main Thread] WARNING: stylo: ServoStyleSets cannot respond to document state changes yet (only matters for chrome documents). See bug 1290285.: file /builds/worker/workspace/build/src/layout/base/PresShell.cpp, line 4297
02:23:42     INFO - GECKO(1786) | [Child 1788, Main Thread] WARNING: stylo: ServoStyleSets cannot respond to document state changes yet (only matters for chrome documents). See bug 1290285.: file /builds/worker/workspace/build/src/layout/base/PresShell.cpp, line 4297
02:23:42     INFO - GECKO(1786) | [Child 1788, Main Thread] WARNING: stylo: Web Components not supported yet: file /builds/worker/workspace/build/src/dom/base/nsDocument.cpp, line 6412
02:23:42     INFO - GECKO(1786) | [Child 1788, Main Thread] WARNING: stylo: Web Components not supported yet: file /builds/worker/workspace/build/src/dom/base/nsDocument.cpp, line 6412
02:23:43     INFO - TEST-INFO | started process screencapture
02:23:43     INFO - TEST-INFO | screencapture: exit 0
02:23:43     INFO - Buffered messages logged at 02:23:42
02:23:43     INFO - must wait for load
02:23:43     INFO - must wait for focus
02:23:43     INFO - Buffered messages logged at 02:23:43
02:23:43     INFO - TEST-PASS | dom/events/test/test_bug574663.html | Normal scrolling shouldn't change zoom 
02:23:43     INFO - Buffered messages finished
02:23:43     INFO - TEST-UNEXPECTED-FAIL | dom/events/test/test_bug574663.html | Normal scrolling should scroll - got 15, expected 18
02:23:43     INFO -     SimpleTest.is@SimpleTest/SimpleTest.js:312:5
02:23:43     INFO -     check@dom/events/test/test_bug574663.html:140:11
02:23:43     INFO -     onpaint@dom/events/test/test_bug574663.html:35:7
02:23:43     INFO -     EventListener.handleEvent*waitForPaint@dom/events/test/test_bug574663.html:42:3
02:23:43     INFO -     postApzFlush@dom/events/test/test_bug574663.html:56:5
This seemed to start with changes for bug 1379587, but note https://bugzilla.mozilla.org/show_bug.cgi?id=1379587#c44.

Most failures are on debug, but perhaps 30% are opt.

:florian - Disable on debug? Disable everywhere? Or can the test be made more reliable?
Blocks: 1379587
Flags: needinfo?(florian)
See Also: → 1319655
Whiteboard: [stockwell needswork]
Attached patch PatchSplinter Review
Locally this seems to help a lot (I can no longer make the test fail using --run-until-failure after applying this patch).
Attachment #8909723 - Flags: review?(mconley)
Assignee: nobody → florian
Status: NEW → ASSIGNED
See Also: 1319655
Duplicate of this bug: 1319655
Comment on attachment 8909723 [details] [diff] [review]
Patch

Review of attachment 8909723 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks! Glad you found a solution - though I look forward to getting rid of these hacks once gandalf's stuff lands. :)
Attachment #8909723 - Flags: review?(mconley) → review+
Pushed by florian@queze.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/976a82102f13
make test_bug574663.html wait until the 'blank' attribute has actually been removed, r=mconley.
https://hg.mozilla.org/mozilla-central/rev/976a82102f13
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Is it something that we want to uplift in 57?
Flags: needinfo?(florian)
(In reply to Sylvestre Ledru [:sylvestre] from comment #12)
> Is it something that we want to uplift in 57?

Yes, but it's a test-only change to fix an intermittent, so (usually) doesn't need approval.
Flags: needinfo?(florian)
sure but still needs to be landed :)
Whiteboard: [stockwell needswork:owner] → [stockwell fixed:timing]
You need to log in before you can comment on or make changes to this bug.