Add an option for showing more / fewer rows in New Tab sections

VERIFIED FIXED in Firefox 62

Status

()

enhancement
P1
normal
VERIFIED FIXED
2 years ago
3 months ago

People

(Reporter: mp3geek, Assigned: rrosario)

Tracking

(Blocks 2 bugs)

57 Branch
Firefox 62
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox 62+, firefox57 wontfix, firefox58 wontfix, firefox60 wontfix, firefox62 verified)

Details

(Whiteboard: [blocked])

Attachments

(2 attachments)

Reporter

Description

2 years ago
Posted image three-rows.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170915192121

Steps to reproduce:

Not sure if its been requested previosly, but the option of having another Row would be nice (since we can't modify the column/row options anymore)


Actual results:

Able to select between 2 or 3 rows as an option if the user wishes


Expected results:

Attached is a sample of how the design would be
Component: Untriaged → New Tab Page

Updated

2 years ago
Severity: normal → enhancement
Component: New Tab Page → Activity Streams: Newtab
Priority: -- → P3

Updated

2 years ago
Duplicate of this bug: 1401533

Updated

2 years ago
Summary: Add an option for 3 rows in New Tab → Add an option for showing more / fewer rows in New Tab
FWIW I'm seeing this feature requested frequently on twitter since firefox quantum released.
Also, as some personal feedback, I found the "edit" feature a bit hard to discover.  For some reason I expected this to either be in the side panel with other settings or at the bottom left of the widget.  I didn't initially look for this kind of feature near the "?" help icon in the upper right of the widget.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

Last year
uiwanted: This was left off in providing more details for `two "more rows" "fewer rows" options`
Keywords: uiwanted

Comment 5

Last year
The design will be via about:preferences perhaps with a dropdown.

Each section (highlights) needs to have a pref to control rows. Top sites might need to convert to rows instead of count.
Blocks: 1432589
Iteration: --- → 60.3 - Feb 26
Priority: P3 → P2
Whiteboard: [AS60MVP]

Comment 6

Last year
uifeedback: https://mozilla.invisionapp.com/share/EGFI16P8Y36#/screens/276669529_Preferences_-_Home_Selected

row drop down are to the right of the section description text

Updated

Last year
Keywords: uiwanted

Updated

Last year
Depends on: 1404890
Whiteboard: [AS60MVP] → [blocked][AS60MVP]
Iteration: 60.3 - Feb 26 → 60.4 - Mar 12

Updated

Last year
Blocks: 1437659

Updated

Last year
Whiteboard: [blocked][AS60MVP] → [blocked][strings needed][AS60MVP]

Comment 7

Last year
Bug 1404890 will land the strings for this bug: {num} row;{num} rows
Whiteboard: [blocked][strings needed][AS60MVP] → [blocked][AS60MVP]
Iteration: 60.4 - Mar 12 → 61.1 - Mar 26
Whiteboard: [blocked][AS60MVP] → [blocked]
Priority: P2 → P3
Iteration: 61.1 - Mar 26 → ---

Updated

Last year
Iteration: --- → 61.2 - Apr 9
Priority: P3 → P2

Comment 8

Last year
Bug 1404890 is adding the 1 row/2 rows drop down for top sites, which already has a pref for rows. This bug will need to figure out how to save the user selected rows value for other sections. And also have top sites handle up to 4 rows.
Iteration: 61.2 - Apr 9 → 61.3 - Apr 23
Iteration: 61.3 - Apr 23 → ---

Updated

Last year
Iteration: --- → 62.1 - May 21
Priority: P2 → P3
Blocks: 1444980
No longer blocks: 1437659
Iteration: 62.1 - May 21 → 62.2 - Jun 4
Iteration: 62.2 - Jun 4 → 62.3 - Jun 18
Assignee: nobody → rrosario
I filed a followup to deal with Top Sites - Bug 1465398
Summary: Add an option for showing more / fewer rows in New Tab → Add an option for showing more / fewer rows in New Tab sections

Updated

Last year
Blocks: 1465548
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/49e8a52753049b7565c2cce4da8a6781d1010b79
feat(preferences): Allow user set rows for sections (#4179)

Fix Bug 1400536 - Add an option for showing more / fewer rows in New Tab sections

Updated

Last year
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED

Updated

Last year
Blocks: 1465398

Updated

Last year
Blocks: 1465172
https://hg.mozilla.org/mozilla-central/rev/609a288fe314
Iteration: 62.3 - Jun 18 → 62.2 - Jun 4
Priority: P3 → P1
Target Milestone: --- → Firefox 62
The issue is no longer reproducible on the latest Nightly 62.0a1 (Build ID 20180604100129) on Windows 10 x64, Mac 10.13.4 and Ubuntu 16.04 x32. The "Recommended by Pocket" and "Highlights" sections can now be customized to show up to 4 rows.
Status: RESOLVED → VERIFIED
Is that something we want to add to the release notes?
Flags: needinfo?(edilee)
Maria, comment 14 for 62, should there be release notes relating to these customization changes? If so, probably could be mentioned with bug 1465398 so all sections (top sites, pocket, highlights) can be configured 1 to 4 rows now.
Flags: needinfo?(edilee) → needinfo?(mpopova)
Adding to the beta 62 release notes as:

New tab page sections such as top sites, highlights, and Pocket can be adjusted to include 1 to 4 rows in the Preferences

If you'd like to change that wording, please let me know.

Updated

3 months ago
Flags: needinfo?(mpopova)
You need to log in before you can comment on or make changes to this bug.