Crash in mozilla::gfx::SourceSurfaceVolatileData::Map

RESOLVED FIXED in Firefox 57

Status

()

--
critical
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: calixte, Assigned: aosmond)

Tracking

(Blocks: 1 bug, {crash, regression, topcrash})

57 Branch
mozilla57
Unspecified
Android
crash, regression, topcrash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 fixed)

Details

(Whiteboard: [clouseau], crash signature)

(Reporter)

Description

a year ago
This bug was filed from the Socorro interface and is 
report bp-1f2bfa88-2029-49f5-bd43-4b3fe0170916.
=============================================================

There are 41 in nightly 57 with buildid 20170916100147 and 73 for FennecAndroid with buildid 20170916100141. 
In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1380649.

[1] https://hg.mozilla.org/mozilla-central/rev?node=722569a89186be92efbaebfa99005e5c46e27cf5
Flags: needinfo?(aosmond)
(Reporter)

Comment 1

a year ago
The signature is ranked #4 in nightly top-crashers for FennecAndroid.
Keywords: topcrash
(Assignee)

Comment 2

a year ago
I was expecting the diagnostic assert to crash (to figure out what went wrong) but not nearly as often as we are seeing (it was relatively rarely observed, or so I thought...). Backed out the offending change and I think the traces I've looked at gave me the information I needed to solve the original problem.
Flags: needinfo?(aosmond)

Comment 3

a year ago
I'm apparently experiencing this crash pretty regularly on macOS 10.12.6 today, so if you need any additional info or testing let me know.
https://hg.mozilla.org/mozilla-central/rev/b3f6d72c338e
Assignee: nobody → aosmond
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox57: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Duplicate of this bug: 1400613
FWIW, this also ended up being a top crash on OSX, with a staggering 90% of all OSX crashes.
(Assignee)

Comment 7

a year ago
(In reply to Andrew McCreight [:mccr8] from comment #6)
> FWIW, this also ended up being a top crash on OSX, with a staggering 90% of
> all OSX crashes.

Yes. My apologies. Really, given 3 reports over 2 years of images occasionally missing off pages in Firefox, I did not expect it to be happening constantly to every nightly user :(. This has not been a good weekend for me and crashes it seems.
(Assignee)

Updated

a year ago
Duplicate of this bug: 1400706
You need to log in before you can comment on or make changes to this bug.