Closed Bug 1400868 Opened 4 years ago Closed 4 years ago

Intermittent leakcheck | tab process: 7648 bytes leaked (nsDisplayLayerEventRegions, nsDisplayTransform, nsDisplayWrapList, nsRect, nsTArray_base)

Categories

(Core :: Graphics: WebRender, defect, P1)

57 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: kats)

References

Details

(Keywords: intermittent-failure, Whiteboard: [wr-mvp] [gfx-noted])

Attachments

(1 file)

Assignee: nobody → bugmail
OS: Unspecified → Linux
Priority: P5 → P1
Hardware: Unspecified → x86_64
Whiteboard: [gfx-noted][wr-mvp][triage]
Version: unspecified → 57 Branch
This should be fixed on autoland by the backout in https://bugzilla.mozilla.org/show_bug.cgi?id=1400034#c26 but we'll need to fix it properly before relanding, so let's keep this bug open and blocking bug 1400888.
I can reproduce a leak of some nsDisplayLayerEventRegions when I run the transform-3d/backface-visibility-1b.html reftest locally on a debug build. I'll investigate.
That one was introduced in https://hg.mozilla.org/mozilla-central/rev/f8712cfa2588#l2.12 - we're not destroying the display item before "continue"ing.
Blocks: 1392200
Status: NEW → ASSIGNED
Whiteboard: [gfx-noted][wr-mvp][triage] → [wr-mvp] [gfx-noted]
Target Milestone: --- → mozilla57
Attachment #8909351 - Flags: review?(mtseng) → review?(jmuizelaar)
Redirecting review since Morris is on PTO ^
Comment on attachment 8909351 [details]
Bug 1400868 - Destroy backface-hidden display items that we're not going to process.

https://reviewboard.mozilla.org/r/180894/#review186522
Attachment #8909351 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/05c577db8142
Destroy backface-hidden display items that we're not going to process. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/05c577db8142
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.