Closed Bug 1400888 Opened 2 years ago Closed 2 years ago

Turn on layers-free for transform/ and transform-3d/ reftests

Categories

(Core :: Graphics: WebRender, enhancement, P1)

57 Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- unaffected

People

(Reporter: kats, Assigned: kats)

References

Details

(Whiteboard: [wr-mvp] [gfx-noted])

Attachments

(2 files)

I tried turning on layers-free for the transform/ and transform-3d/ reftests in bug 1400034, but it exposed some leaks and intermittent fuzzy failures so we backed it out. The leaks are permafail on R8 debug, the fuzzies affect a few different transform-3d tests. See the R8 jobs on the following:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=583a3dec5b1d4099aec9d3916229ff3bb1b4e0ba

https://treeherder.mozilla.org/#/jobs?repo=autoland&fromchange=1e2233c98ff1e88570cf61b52ee3bf57e39950df&filter-searchStr=qr&group_state=expanded&bugfiler&tochange=776c180fb82ac7e04ffc9b72a9691930a3eae019
I went through all the R8 failures in the above links and listed the fuzzy-fails:

from the try push
/transform-3d/rotatey-1a.html (1,6)
/transform-3d/perspective-origin-1b.html (1,1)
/transform-3d/rotatex-transformorigin-1a.html (1,2)
/transform-3d/rotatex-transformorigin-1a.html (1,1)
/transform-3d/perspective-origin-1b.html (1,1)
/transform-3d/rotatex-transformorigin-1a.html (1,1)
/transform-3d/rotatex-transformorigin-1a.html (1,1)
/transform-3d/perspective-origin-1b.html (1,1)
/transform-3d/rotatex-transformorigin-1a.html (1,1)

from autoland
/transform-3d/rotatey-1a.html (1,2)
/transform-3d/rotatey-1a.html (1,4)
/transform-3d/rotatey-1a.html (1,4)
/transform-3d/rotatey-1a.html (1,6)
/transform-3d/perspective-origin-1b.html (1,1)
/transform-3d/rotatey-1a.html (1,2)
/transform-3d/perspective-origin-1b.html (1,1)

So that boils down to this:
transform-3d/rotatey-1a.html -> (0-1,0-6)
transform-3d/perspective-origin-1b.html -> (0-1,0-1)
transform-3d/rotatex-transformorigin-1a.html -> (0-1,0-1)
Status: NEW → ASSIGNED
Priority: P3 → P1
Whiteboard: [gfx-noted][wr-mvp][triage] → [wr-mvp] [gfx-noted]
Target Milestone: --- → mozilla57
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #1)
> So that boils down to this:
> transform-3d/rotatey-1a.html -> (0-1,0-6)
> transform-3d/perspective-origin-1b.html -> (0-1,0-1)
> transform-3d/rotatex-transformorigin-1a.html -> (0-1,0-1)

I applied these fuzzes and things are looking good: https://treeherder.mozilla.org/#/jobs?repo=try&revision=fcf1c207014ce2bdd8b462cd86aa87bc277c1d02

I'll put up two patches for review. One is the part3 patch from bug 1400034 which was already r+'d on that bug (and landed and then backed out). The other is the above fuzzes to make the reftests green.
Comment on attachment 8909390 [details]
Bug 1400888 - Turn on layers-free for transform/ and transform-3d/ reftests.

https://reviewboard.mozilla.org/r/180910/#review186392
Attachment #8909390 - Flags: review?(ethlin) → review+
Comment on attachment 8909391 [details]
Bug 1400888 - Mark some transform-3d reftests intermittently fuzzy in layers-free webrender.

https://reviewboard.mozilla.org/r/180912/#review186394
Attachment #8909391 - Flags: review?(ethlin) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2a0c39ba138b
Turn on layers-free for transform/ and transform-3d/ reftests. r=ethlin
https://hg.mozilla.org/integration/autoland/rev/f1cbf53a14ea
Mark some transform-3d reftests intermittently fuzzy in layers-free webrender. r=ethlin
No longer depends on: 1400881
Duplicate of this bug: 1400881
You need to log in before you can comment on or make changes to this bug.