Closed Bug 1401232 Opened 2 years ago Closed 2 years ago

Sidebar not reopened when upgrading from build before bug 1391280 to build after bug 1391280

Categories

(Firefox :: General, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.3 - Sep 19
Tracking Status
firefox57 --- verified

People

(Reporter: Gijs, Assigned: Gijs)

References

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(1 file)

STR:

1. clean profile on build from Sept 13 or earlier
2. open bookmarks sidebar
3. close firefox
4. run build with current nightly

ER:

bookmarks sidebar is open

AR:

bookmarks sidebar is not open


We could potentially fix this with a UI migration in nsBrowserGlue.js (I think). I'm undecided as to whether that's worth the effort. It would also disrupt nightly users in that it would reopen a closed sidebar for them.

Brian, thoughts?
Flags: needinfo?(bgrinstead)
I'd prioritize getting it right for release users over disrupting Nightly users **if** we could come up with a simple and low-risk migration. Is the solution here basically setting "checked" to true in the xul store if "sidebarcommand" is non-empty, or is it more complicated than that?
Flags: needinfo?(bgrinstead) → needinfo?(gijskruitbosch+bugs)
(In reply to Brian Grinstead [:bgrins] from comment #1)
> Is the
> solution here basically setting "checked" to true in the xul store if
> "sidebarcommand" is non-empty, or is it more complicated than that?

I believe that's what it would take, yes, but I have not yet tried it.
Flags: needinfo?(gijskruitbosch+bugs)
I'll come up with a patch tomorrow.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Priority: -- → P3
Whiteboard: [reserve-photon-structure]
Flags: qe-verify+
Priority: P3 → P1
QA Contact: gwimberly
Iteration: --- → 57.3 - Sep 19
Note to self: need to rebase around bug 1388422 which is also adding a UI migration.
Comment on attachment 8910241 [details]
Bug 1401232 - ensure sidebar persists correctly on update,

https://reviewboard.mozilla.org/r/181732/#review187110

I've tested this in three ways (the nightly I was using is from 09-08-2017)

1) Make a profile on nightly. Run the same profile with this patch applied = sidebar isn't opened
2) Make a profile on nightly and open then close the bookmarks sidebar. Run the same profile with this patch applied = bookmarks sidebar isn't opened
3) Make a profile on nightly and open bookmarks sidebar.  Run the same profile with this patch applied = bookmarks sidebar is opened

These all seem right to me and it makes sense, since there shouldn't be anything in the store for (1), and we did set the sidebarcommand to an empty string after closing before so the call to `xulStore.getValue` should be falsy for (2).
Attachment #8910241 - Flags: review?(bgrinstead) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/39b1badf8930
ensure sidebar persists correctly on update, r=bgrins
https://hg.mozilla.org/mozilla-central/rev/39b1badf8930
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
I have verified that the issue mentioned in comment 0 is not reproducible using Firefox 57.0b9 (Build Id:20171016185129) on Windows 10 64bit, macOS 10.11.6 and Ubuntu 16.04 64bit.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.