Closed Bug 1401238 Opened 2 years ago Closed 2 years ago

Deprecate Recent Bookmarks, and Pocket List from the Bookmarks Menu.

Categories

(Firefox :: Menus, enhancement, P1)

57 Branch
enhancement

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.3 - Sep 19
Tracking Status
firefox57 --- verified

People

(Reporter: bbell, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(3 files)

Recent Bookmarks and the Pocket list no longer needs representation in the bookmarks menu. By default, these items are available in The Library which means we can return the real estate we needed to occupy (because we didn't have a place to show these things before) back to the user.
Whiteboard: [photon-structure]
Flags: qe-verify?
Priority: -- → P3
Whiteboard: [photon-structure] → [reserve-photon-structure]
Per conversation with Bryan, remove these things out of both the toplevel menu and the bookmarks menu button.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Iteration: --- → 57.3 - Sep 19
Flags: qe-verify? → qe-verify+
Priority: P3 → P1
QA Contact: gwimberly
I'm deliberately not removing strings in case we end up on beta and discover reasons we can't / don't want to ship this. Assuming this is OK, I will file bugs on the exact strings that need removing in 58.
(In reply to :Gijs from comment #4)
> I'm deliberately not removing strings in case we end up on beta and discover
> reasons we can't / don't want to ship this. Assuming this is OK, I will file
> bugs on the exact strings that need removing in 58.

Good idea.
Comment on attachment 8910051 [details]
Bug 1401238 - remove pocket entries in bookmarks menu button panel and bookmarks menu,

https://reviewboard.mozilla.org/r/181522/#review186834
Attachment #8910051 - Flags: review?(jaws) → review+
Comment on attachment 8910050 [details]
Bug 1401238 - remove recent bookmarks from the bookmarks menu button and toplevel bookmarks menu,

https://reviewboard.mozilla.org/r/181520/#review187068

From a code point of view, I'm extremely happy to see this going away!
Attachment #8910050 - Flags: review?(mak77) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/b2cc2a664545
remove recent bookmarks from the bookmarks menu button and toplevel bookmarks menu, r=mak
https://hg.mozilla.org/integration/autoland/rev/3e62ada45977
remove pocket entries in bookmarks menu button panel and bookmarks menu, r=jaws
Blocks: 1401527
https://hg.mozilla.org/mozilla-central/rev/b2cc2a664545
https://hg.mozilla.org/mozilla-central/rev/3e62ada45977
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Not sure what I'm missing here, but I just installed latest m-c win32 hourly 
build from cset https://hg.mozilla.org/mozilla-central/rev/319a34bea9e4f3459886b5b9e835bd338320f1fd that contains this patch from I see from treeherder.

Clicking on Bookmarks Icon that I placed o the navbar the 'Recent Bookmarked/Pocket entries as shown in the attachment included in this bug is still present.
Closer look shows that Pocket is removed, Recent Bookmark are still present in the Bookmarks button on NavBar.
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #10)
> Not sure what I'm missing here, but I just installed latest m-c win32 hourly 
> build from cset
> https://hg.mozilla.org/mozilla-central/rev/
> 319a34bea9e4f3459886b5b9e835bd338320f1fd that contains this patch from I see
> from treeherder.
> 
> Clicking on Bookmarks Icon that I placed o the navbar the 'Recent
> Bookmarked/Pocket entries as shown in the attachment included in this bug is
> still present.

You're either not *actually* testing with that build or you're using a "bookmarks icon" that I'm unaware of. Both the markup and the JS for these items is gone in that rev. I just tested it myself (on osx).

Please re-test on a clean profile and, if you're still having issues, file a new bug with more details.
Flags: needinfo?(jmjeffery)
(In reply to :Gijs from comment #12)
> (In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #10)
> > Not sure what I'm missing here, but I just installed latest m-c win32 hourly 
> > build from cset
> > https://hg.mozilla.org/mozilla-central/rev/
> > 319a34bea9e4f3459886b5b9e835bd338320f1fd that contains this patch from I see
> > from treeherder.
> > 
> > Clicking on Bookmarks Icon that I placed o the navbar the 'Recent
> > Bookmarked/Pocket entries as shown in the attachment included in this bug is
> > still present.
> 
> You're either not *actually* testing with that build or you're using a
> "bookmarks icon" that I'm unaware of. Both the markup and the JS for these
> items is gone in that rev. I just tested it myself (on osx).
> 
> Please re-test on a clean profile and, if you're still having issues, file a
> new bug with more details.

I just doublechecked with win32, and I see the same thing there, for https://queue.taskcluster.net/v1/task/f-Ts7Ce-R8aix78Lv_LABA/runs/0/artifacts/public/build/target.zip . If you're using the stub installer, maybe it's downloading an earlier full installer? Check about:buildconfig of the build you're actually running to verify what revision it's from.
Confirming with about:buildconfig https://hg.mozilla.org/mozilla-central/rev/319a34bea9e4f3459886b5b9e835bd338320f1fd

TC shows that patches are included in that cset.
I always download the 'full installer' / using add/remove programs remove the previous build, then run the installer.

Will test a new profile in a few mins.
Flags: needinfo?(jmjeffery)
New Profile - Recently Bookmarked is still showing under the Bookmark button the NavBar.
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #15)
> New Profile - Recently Bookmarked is still showing under the Bookmark button
> the NavBar.

As I said before, please file a new bug with screenshots and more details.
Flags: needinfo?(jmjeffery)
I can't clear the 'needinfo' flag.  I uncheck the box below but it does not clear.

This bug does not remove the Recent Bookmarks in a dirty profile.  I had a death in family and not had to follow up.

New Profile clean.  Recently Bookmarked is not present in the Bookmarks drop-down.
Copy/Paste places.sqlite from exiting Profile into the new Profile.
Now.. Recently bookmarked appears.

Seems patch is not cleaning up places.sqlite or something...
Flags: needinfo?(jmjeffery)
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #17)
> I can't clear the 'needinfo' flag.  I uncheck the box below but it does not
> clear.

Keep the "clear the needinfo request for ..." box checked and the flag will be removed. It seems you succeeded at this point.  :-)

> This bug does not remove the Recent Bookmarks in a dirty profile.  I had a
> death in family and not had to follow up.

My condolences. No rush, this stuff is obviously not important by comparison.

> New Profile clean.  Recently Bookmarked is not present in the Bookmarks
> drop-down.
> Copy/Paste places.sqlite from exiting Profile into the new Profile.
> Now.. Recently bookmarked appears.

Where exactly are you seeing this? Unfortunately I am still not able to reproduce this.

> Seems patch is not cleaning up places.sqlite or something...

We don't intend to remove any bookmarks, so places.sqlite shouldn't be affected. What's happening here is that:
1) we no longer show the "Recent bookmarks" section in the toplevel bookmarks menu (from the old-style menubar) - but will still show bookmarks filed in the bookmarks menu.
2) we no longer show the "Recent bookmarks" section in the bookmarks menu button's menu panel (this is the separate button with a star over a line/tray icon, which is no longer visible by default) - but will still show bookmarks filed in the bookmarks menu.
3) we *still* show recent bookmarks as part of the "bookmarks" section in the library panel (the button with an icon of several books), and if you move the 'bookmarks toolbar items' item into the overflow menu (it'll show the same thing as the 'bookmarks' section of the library menu).
4) as of bug 1354536, we show 'recent highlights' in the library panel itself, which may include bookmarks (depends on various factors).

If this doesn't match what you're seeing, please file a separate bug with a screenshot of what you're seeing, when convenient.
Please see:  https://imgur.com/a/g9rVv  

This is from the Bookmarks Icon added to NavBar from Customize.

Please sdd: https://imgur.com/a/chayx 

This from the Library Icon in the Hamburger Menu bar->Bookmarks

After seeing your post it appears that I have completely misunderstood the nature of the patch.  

Thanks Gijs for your patience.
Should mention the above was from my 'working' Profile, not a completely clean one.
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #19)
> After seeing your post it appears that I have completely misunderstood the
> nature of the patch.  
> 
> Thanks Gijs for your patience.

No worries, glad we got it sorted out. Gonna call this verified based on those screenshots. :-)
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: qe-verify-
Blocks: 1437651
You need to log in before you can comment on or make changes to this bug.