Make sure the JAWS prompt doesn't trigger in non-e10s

VERIFIED FIXED in Firefox 57

Status

()

P1
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: jimm, Assigned: jimm)

Tracking

Trunk
mozilla58
All
Windows
Points:
---

Firefox Tracking Flags

(firefox56 unaffected, firefox57+ verified, firefox58 verified)

Details

(Whiteboard: aes+)

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

a year ago
Thought of this last night and it looks like it may be possible, I need a e10s check in here [1] somewhere.

[1] https://bugzilla.mozilla.org/attachment.cgi?id=8905940&action=diff
(Assignee)

Updated

a year ago
Assignee: nobody → jmathies
Priority: -- → P1
status-firefox58: --- → affected
tracking-firefox57: ? → +
(Assignee)

Comment 2

a year ago
Comment on attachment 8911327 [details] [diff] [review]
patch

Add a check to make sure we don't prompt if e10s is off. Looks like felipe is on pto, Jared, would you mind looking this over? It's a very straight forward change.
Attachment #8911327 - Flags: review?(jaws)
Double checking, jimm, jaws, is this for 57 only?
status-firefox56: --- → unaffected
Flags: needinfo?(jmathies)
Flags: needinfo?(jaws)
If bug 1385991 gets uplifted to 56 then we will need to uplift this to 56 as well.
Flags: needinfo?(jmathies)
Flags: needinfo?(jaws)
(Assignee)

Comment 5

a year ago
Created attachment 8911909 [details] [diff] [review]
patch
Attachment #8911327 - Attachment is obsolete: true
Attachment #8911909 - Flags: review+
(Assignee)

Updated

a year ago
Keywords: checkin-needed
(Assignee)

Comment 6

a year ago
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #3)
> Double checking, jimm, jaws, is this for 57 only?

57 only.
(Assignee)

Comment 7

a year ago
Created attachment 8911946 [details] [diff] [review]
patch

- updated commit message with r+ from jared
Attachment #8911909 - Attachment is obsolete: true
Attachment #8911946 - Flags: review+

Comment 8

a year ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d8d8c0972cb4
Avoid prompting about compatibility issues with JAWS when e10s is pref'd off. r=jaws
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d8d8c0972cb4
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox58: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Hi Jim, should we uplift this fix to Beta57?
Flags: needinfo?(jmathies)
(Assignee)

Comment 11

a year ago
Comment on attachment 8911946 [details] [diff] [review]
patch

Approval Request Comment
[Feature/Bug causing the regression]:
bug 1385991 
[User impact if declined]:
buggy prompting code for a11y
[Is this code covered by automated tests?]:
no
[Has the fix been verified in Nightly?]:
yes
[Needs manual test from QE? If yes, steps to reproduce]: 
yes, 

STR: 
1) disable e10s in 57, close firefox
2) launch old 8.0 JAWS client
3) launch firefox

expected result: no e10s+a11y prompt
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]:
no
[Why is the change risky/not risky?]:
well understood change
[String changes made/needed]:
none
Flags: needinfo?(jmathies)
Attachment #8911946 - Flags: approval-mozilla-beta?
Comment on attachment 8911946 [details] [diff] [review]
patch

Improve jaws support, taking it.
Should be in 57b5
Attachment #8911946 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 13

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/75e965089708
status-firefox57: affected → fixed
Flags: qe-verify+
Verified fixed in Beta 57.b13. 
There is no prompt showing up in Nightly with e10s ON or OFF. This may be because of Bug 1413599 comment 5.
status-firefox57: fixed → verified
Verified Fixed in 58.b6. No prompt is shown when e10s is off.
Status: RESOLVED → VERIFIED
status-firefox58: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.