Last Comment Bug 140176 - Very very slow to load
: Very very slow to load
Status: VERIFIED DUPLICATE of bug 144442
[pipelining]
: regression, relnote
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: Trunk
: x86 All
: -- major (vote)
: Future
Assigned To: Darin Fisher
: Tom Everingham
Mentors:
https://pe.lsbdirect.com/pbi1961.asp?...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-25 16:20 PDT by David G King
Modified: 2002-08-06 15:56 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description David G King 2002-04-25 16:20:09 PDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020425
BuildID:    2002042510-TRUNK

This page is the login page to my bank. I'd noticed that it had become very slow
to load (like more than 15 minutes). Also, subsequent pages (after I login) are
also very very slow.

After testing using Netscape 4.79 without any trouble, I have to say it's a bug
in Mozilla.

Reproducible: Always
Steps to Reproduce:
1. Open URL
2. Wait
3. Wait some more
4. Go get a coffee and wait some more.

Actual Results:  Takes a long time to display page.

Expected Results:  Load in a few seconds as with Netscape 4.79

I'm marking this as Critical as the average use would consider this a Hang.
Comment 1 Vadim Berezniker 2002-04-25 17:02:10 PDT
-> networking

os -> all

No problem if you disable keep-alive, but w/o keep-alive stuff is extremely slow
to load. 
Comment 2 R.K.Aa. 2002-04-25 17:12:16 PDT
reassign
Comment 3 Darin Fisher 2002-04-25 17:17:40 PDT
cc'ing PSM folks in case this has something to do with PSM.
Comment 4 Boris Zbarsky [:bz] (Out June 25-July 6) 2002-04-25 18:56:04 PDT
confirming that keep-alive makes this very slow...
Comment 5 David G King 2002-04-26 04:22:26 PDT
Adding keyword "regression" as it works fine with 1.0RC1.
Comment 6 David G King 2002-04-26 04:28:14 PDT
Has anyone seen this on the 1.0.0 BRANCH?

I will be testing a latest BRANCH build tonight (EDT), but if someone else has
already done so, it will save me the hassle.
Comment 7 Jacek Piskozub 2002-04-26 05:55:47 PDT
Isn't it caused by the patch for bug 125561 which landed (trunk only) on 4/19? 
Comment 8 Jacek Piskozub 2002-04-26 06:22:15 PDT
The testcase WFM with the most recent 1.0 branch build (2002042506).
Comment 9 David G King 2002-04-26 06:26:52 PDT
I've just tested 2002042506-BRANCH and it works fine.

From reading Bug #125561, it looks like this may be a dup. As such, I recommend
that the patch for that bug does not get checked into the Branch. 
Comment 10 Kai Engert (:kaie) 2002-04-26 09:17:58 PDT
Why do you think it is the patch from bug 125561?
Did somebody test a trunk build where that patch was reverted, to see whether it
indeed is the cause of the problem?

When I look at the context at that patch, I have the impression, that new code
is only called when one of the following events is broadcasted:
- "session-logout"
- "profile-before-change"

IMHO, until you quit the application or switch the profile in turbo mode, this
code can't be the cause.
Comment 11 David G King 2002-04-26 09:33:42 PDT
I don't have a C compiler, so I can't backout or build code.

I'm guessing that your fix was applied to the Trunk on 4/19, so I'm getting a
4/18 build to try it.
Comment 12 David G King 2002-04-26 09:48:07 PDT
A 4/18 build works fine. I can't find a Windows build for 4/20 or 4/21 so can't
test that much further.
Comment 13 Jacek Piskozub 2002-04-26 11:03:41 PDT
> Why do you think it is the patch from bug 125561?

Simply because it was the only keep-alive patch in recent days. 

I have presently at home only a modem connection paid per minute, so I do not
build Mozilla anymore :-(
Comment 14 R.K.Aa. 2002-04-28 19:00:11 PDT
The images load if HTTP pipelining is turned off, but not when it's turned on.
Perhaps this should be resolved as dup of bug 140561, which has a more exact
summary.
Comment 15 David G King 2002-04-29 05:40:30 PDT
I'm not sure if this is a dup of #140561. There is no mention in that bug about
the fact that the images will load if given enough time.
Comment 16 Gavin Jackson 2002-05-09 00:29:16 PDT
That site WFM on 2002050807 win2k
Comment 17 David G King 2002-05-09 15:52:01 PDT
Gavin, do you have HTTP pipelining turned on? The reason I ask is that with
build 20020509-TRUNK it still doesn't work for me on Win98SE.
Comment 18 Darin Fisher 2002-05-14 14:36:36 PDT
reducing severity to major since this only seems to happen when pipelining is
enabled.
Comment 19 David G King 2002-05-14 14:45:12 PDT
Adding RELNOTE keyword as it looks like this isn't going to be fixed for Mozilla
1.0. People need to know that turning on pipelining can break page loads.
Comment 20 Darin Fisher 2002-05-17 16:23:29 PDT
mass futuring of untargeted bugs
Comment 21 Darin Fisher 2002-05-21 13:33:44 PDT
looks like this bug is caused by problems with IIS/4.0 ... i've seen other sites
that have similar troubles.  the common problem is IIS/4.0 seems to ignore
subsequent requests in a pipelined request.  it never responds to them, and as a
result, mozilla ends up waiting for a very long time.  the solution (i think) is
to disable pipelining when speaking to IIS/4.0.  working on a patch.
Comment 22 Darin Fisher 2002-05-21 13:36:39 PDT

*** This bug has been marked as a duplicate of 144442 ***
Comment 23 Tom Everingham 2002-08-06 15:56:29 PDT
verified dup

Note You need to log in before you can comment on or make changes to this bug.