Closed Bug 1402005 Opened 2 years ago Closed 2 years ago

Add a link to SUMO page about new Activity Stream experience

Categories

(Firefox for Android :: General, enhancement, P1)

ARM
Android
enhancement

Tracking

()

VERIFIED FIXED
Firefox 58
Iteration:
1.30
Tracking Status
firefox57 --- verified
firefox58 --- verified

People

(Reporter: liuche, Assigned: mcomella)

References

Details

(Whiteboard: [MobileAS])

Attachments

(5 files)

During our triage meeting we followed up with QA, and we discussed that users of Activity Stream might find the new layout to be confusing (or not know about features like "how to turn off Pocket/Highlights").

Should we have a link to a SUMO page on the newtab page, and is there somewhere UX thinks we should put it? We'll have to use existing strings (but we have a "Learn more" string already).
Bryan, can you comment on this?
tracking-fennec: ? → ---
Flags: needinfo?(bbell)
let's place a link at the bottom of the New Tab that links to a SUMO page that explains what's going on.
Flags: needinfo?(bbell)
Attached file help-small.zip
icon needed.
Here's the link to the WIP page (content will be up by 57 release):
https://support.mozilla.org/1/mobile/%VERSION%/%OS%/%LOCALE%/activity-stream
Flags: needinfo?(s.kaspari)
Assignee: nobody → michael.l.comella
On Slack, I asked bbell if the question mark was acceptable in all locales, and he responded that I should drop it and center the type instead.
Comment on attachment 8911424 [details]
Bug 1402005: Add a learn more link to Top Sites.

https://reviewboard.mozilla.org/r/182882/#review188116
Attachment #8911424 - Flags: review?(liuche) → review+
Comment on attachment 8911426 [details]
Bug 1402005: Add telemetry for Learn More clicks.

https://reviewboard.mozilla.org/r/182884/#review188124

r+, data-r+ because collecting Type 2 user interactions.
Attachment #8911426 - Flags: review?(liuche) → review+
Pushed by michael.l.comella@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a3fa131f4e0f
Add a learn more link to Top Sites. r=liuche
https://hg.mozilla.org/integration/autoland/rev/20527b1071a3
Add telemetry for Learn More clicks. r=liuche
Comment on attachment 8911424 [details]
Bug 1402005: Add a learn more link to Top Sites.

Approval Request Comment
[Feature/Bug causing the regression]: Activity Stream top sites
[User impact if declined]: Activity Stream changed the appearance of top sites and we're concerned that 1) users will be confused by the new layout or 2) they will be unable to find new features like the ability to hide different parts of top sites (e.g. Pocket). This patch adds a link to the SUMO article for Android Activity Stream so if declined, users may struggle with the new layout.

[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: Ideally. Bogdan can verify, though the link will 404 until bug 1400945 lands (when the SUMO page is complete).
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: Medium-low.
[Why is the change risky/not risky?]: The code to add the view with the Learn More link is simple and tends to not be error prone. However, we modified the algorithm for how highlights are added to the list, which can sometimes be error prone though I patterned my code after existing code (how we add Pocket items) so I'm not that concerned. The code is also called frequently so errors are likely to be seen through minimal testing. Additionally, a fair number of lines were changed so risk is added just by the size of the change.

[String changes made/needed]: None
Attachment #8911424 - Flags: approval-mozilla-beta?
Comment on attachment 8911426 [details]
Bug 1402005: Add telemetry for Learn More clicks.

Approval Request Comment: see comment 13.
Attachment #8911426 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/a3fa131f4e0f
https://hg.mozilla.org/mozilla-central/rev/20527b1071a3
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Comment on attachment 8911424 [details]
Bug 1402005: Add a learn more link to Top Sites.

Add more docs to the new feature, taking it.
should be in 57b3
Attachment #8911424 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #8911426 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
A Learn More button was added to the bottom of the page. It works as expected without causing any other issues. Marking this as verified as the actual SUMO page will be treated in bug 1400945.
Flags: needinfo?(s.kaspari)
Verified in beta as well.
Status: RESOLVED → VERIFIED
Using Fennec nightly, the "learn more" link leads to a 404 for me. Running Android Oreo on a Google Pixel.

STR:
1. Load about:home
2. Scroll to bottom of page.
3. Click on "Learn More" link
4. I get a 404 - https://support.mozilla.org/en-US/kb/activity-stream?as=u&utm_source=inproduct
(In reply to Marcia Knous [:marcia - use ni] from comment #20)
> Using Fennec nightly, the "learn more" link leads to a 404 for me. Running
> Android Oreo on a Google Pixel.

This is expected until the SUMO page is completed: bug 1400945. This is mentioned in comment 13.
You need to log in before you can comment on or make changes to this bug.