Closed Bug 1402067 Opened 4 years ago Closed 4 years ago

webrender: tab crash while playing a youtube video (Crashing Thread: MediaPDecoder)

Categories

(Core :: Graphics: WebRender, defect)

x86_64
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1407069
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected

People

(Reporter: jan, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: crash, nightly-community, Whiteboard: [gfx-noted])

Nightly 57 x64 20170921100141 de_DE @ Debian Testing (KDE / Radeon RX 480)
This is reproducible for me and happens for months.
I don't remember this correctly, but I think this happens since I have to enable layers.acceleration.force-enabled to be able to activate WebRender.

No clear crash reason/signature
> Crashing Thread (XX), Name: MediaPDecoder #XX

bp-948a2a6c-dd39-4393-8ac2-0e1270170921	21.09.17 20:21
> layers.acceleration.force-enabled;true
> gfx.webrender.enabled;true

bp-b0da919e-3a5b-4079-a8f4-cd68c0170921	21.09.17 20:17
> layers.acceleration.force-enabled;true
> layers.gpu-process.enabled;true
> layers.gpu-process.force-enabled;false
> gfx.webrender.enabled;true

bp-02904595-3b52-4cc0-a2d5-105e00170921	21.09.17 20:13
bp-a618350d-9039-4bb3-9fc3-486c90170921	21.09.17 18:31
> I think these were so:
> layers.acceleration.force-enabled;true
> layers.gpu-process.enabled;true
> layers.gpu-process.force-enabled;false
> gfx.webrender.enabled;true
> gfx.webrendest.enabled;false
> gfx.webrender.layers-free;false

If I'm not wrong, there was also a case (with blob-image?) where the video gets black at some point, but with a still playing audio.
Priority: -- → P3
Whiteboard: [gfx-noted]
Priority: P3 → P2
Whiteboard: [gfx-noted] → [wr-mvp] [gfx-noted]
:darkspirit, is the crash still happen?
Flags: needinfo?(jan)
(In reply to Sotaro Ikeda [:sotaro] from comment #2)
> :darkspirit, is the crash still happen?

Every time I get a crash on YouTube, I leave a "webrender youtube" comment. But I didn't watch longer videos the last days.

https://crash-stats.mozilla.com/search/?user_comments=~webrender%20youtube&product=Firefox&date=%3E%3D2017-10-01T03%3A09%3A17.000Z&date=%3C2017-11-01T02%3A09%3A17.000Z&_sort=-date&_facets=signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#crash-reports
Flags: needinfo?(jan)
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #3)
> (In reply to Sotaro Ikeda [:sotaro] from comment #2)
> > :darkspirit, is the crash still happen?
> 
> Every time I get a crash on YouTube, I leave a "webrender youtube" comment.
> But I didn't watch longer videos the last days.
> 
> https://crash-stats.mozilla.com/search/
> ?user_comments=~webrender%20youtube&product=Firefox&date=%3E%3D2017-10-
> 01T03%3A09%3A17.000Z&date=%3C2017-11-01T02%3A09%3A17.000Z&_sort=-
> date&_facets=signature&_columns=date&_columns=signature&_columns=product&_col
> umns=version&_columns=build_id&_columns=platform#crash-reports

In the above link, the crash seemed not happen since 21/Oct. And memory leak during video playback was addressed by Bug 1407069. Then I wondered if the problem was addressed.
(In reply to Sotaro Ikeda [:sotaro] from comment #4)
> In the above link, the crash seemed not happen since 21/Oct. And memory leak during video playback was addressed by Bug 1407069. Then I wondered if the problem was addressed.

I just found out that those two 4K videos I watched this weekend were in fact each 20 minutes long. I don't remember if blob-images was enabled or not, but that shouldn't matter. Most crashes in the past happened with 1080p videos. So, yes, you might have fixed it. Thank you!
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1407069
Priority: P2 → --
Whiteboard: [wr-mvp] [gfx-noted] → [gfx-noted]
You need to log in before you can comment on or make changes to this bug.