Status

()

defect
P2
normal
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: anleck, Assigned: rrosario)

Tracking

({nightly-community})

57 Branch
Firefox 59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 wontfix, firefox58 wontfix, firefox59 verified, firefox60 verified)

Details

Attachments

(3 attachments, 1 obsolete attachment)

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170921100141

Steps to reproduce:

Try to drag a Top Site to desired location
(Firefox 57, 58)


Actual results:

Nothing


Expected results:

Top Site should have repositioned - only pinned Sites should be locked in place

Updated

2 years ago
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Component: Untriaged → Activity Streams: Newtab
Ever confirmed: true

Updated

2 years ago
Duplicate of this bug: 1402191
Priority: -- → P2

Comment 2

2 years ago
For the benefit of anyone who found themselves here trying to find a way to reorder the tiles on the "new" New Tab page, there's a solution here[0], in the Mozilla support forum.

Basically, toggle about:config?filter=browser.newtabpage.activity-stream.enabled to "false", rearrange the tiles, then toggle back to "true". You might need to force-reload (Shift+Ctrl/⌘+R) the New Tab page to see the results.

[0] https://support.mozilla.org/en-US/questions/1178312#answer-1030416

Updated

2 years ago
Assignee: nobody → rrosario
Status: NEW → ASSIGNED
Iteration: --- → 1.25

Updated

2 years ago
Summary: Activity stream - Newtab - Unable to Drag and Drop (rearrange) Top Sites → Top Sites drag and drop
Duplicate of this bug: 1421554

Updated

2 years ago
See Also: → 1422882

Updated

a year ago
Blocks: 1403947

Comment 5

a year ago
Posted video video of ce7650f PR3902 (obsolete) —
Aaron, given that we're close to 59 freeze, is the current PR's behavior acceptable to ship as is? In particular:

- the dragged item jumps back to its original spot when the drag position is not directly on top of a site (i.e., in the whitespace between sites)

- on drop, there's a flash of the original sites ordering before it updates

- the original site's position gets its meatball menu shown for the new site (even though the pointer is where the site was dropped)
Flags: needinfo?(abenson)

Comment 6

a year ago
Attachment #8937571 - Attachment is obsolete: true

Comment 7

a year ago
Looks good!
Flags: needinfo?(abenson)

Updated

a year ago
Duplicate of this bug: 1426334

Updated

a year ago
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED

Updated

a year ago
Blocks: 1426774

Updated

a year ago
Blocks: 1427360

Updated

a year ago
Blocks: 1427361

Updated

a year ago
Blocks: 1427359

Updated

a year ago
Blocks: 1427358
I have reproduced this bug with Firefox nightly 58.0a1 (2017-09-21) on Windows 10, 64 Bit.

The Bug's fix is now verified on latest nightly 59.0a1 (2018-01-04).

Build ID       20180104100157
User Agent     Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0
QA Whiteboard: [bugday-20180103]

Updated

a year ago
No longer blocks: 1403947
I have successfully reproduced the bug with Nightly 58.0a1 (2017-09-21) on Ubuntu 12.04 LTS!

This bug's fix is Verified with latest Beta!

Build ID   : 20180209162511
User Agent : Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0

[bugday-20180228]
I have reproduced this bug with Firefox Nightly 58.0a1 (2017-09-21) on Windows 10(x64).

The bug is no longer reproducible on Firefox 60.0a1 (2018-03-05), Firefox 59.0b14 and Firefox 60.0b1DevEd(20180302190033).

Tests were performed under Windows 10(x64), Ubuntu 16.04(x64) and macOS 10.12.6.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.