Closed Bug 1402654 Opened 2 years ago Closed 2 years ago

Allow custom image / thumbnail for an edited top site

Categories

(Firefox :: New Tab Page, enhancement, P2)

57 Branch
enhancement

Tracking

()

RESOLVED FIXED
Firefox 61
Iteration:
61.1 - Mar 26
Tracking Status
firefox57 --- wontfix
firefox58 --- wontfix
firefox59 --- wontfix
firefox60 --- wontfix
firefox61 --- fixed

People

(Reporter: anleck, Assigned: andreio)

References

(Blocks 1 open bug)

Details

(Whiteboard: [strings landed] [ThemeCust-MVP])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20170923100045

Steps to reproduce:

Load about:home or about:newtab with Top Sites enabled
Have multiple Youtube channels pinned (or another site with a Rich Icon)


Actual results:

Multiple youtube channels are pinned, each obviously displaying the same icon.
This is aesthetically poor and while tastes may differ, given the small size of the tiles (compared to old non-compact newtab tiles) Label length is often truncated.


Expected results:

Given the identical tile icons and label length limits, Top Site identification may be problematic - especially for those with Visual Impairments.

Allow option to use Thumbnails instead of Rich Icons (site by site being preferred) to aid in site recognition.
Component: Untriaged → Activity Streams: Newtab
Severity: normal → enhancement
Duplicate of this bug: 1402655
Summary: Replace Rich Icons with Thumbnails to Improve Top Site Identification → Allow custom image / thumbnail for an edited top site
Duplicate of this bug: 1401532
Duplicate of this bug: 1421430
Assignee: nobody → andrei.br92
Status: UNCONFIRMED → ASSIGNED
Iteration: --- → 1.25
Ever confirmed: true
Priority: -- → P1
Blocks: 1401464
Iteration: 1.25 → 1.26
Iteration: 1.26 → 1.27
Iteration: 1.27 → 60.1 - Jan 29
Whiteboard: [AS60MVP]
Iteration: 60.1 - Jan 29 → 60.2 - Feb 12
Iteration: 60.2 - Feb 12 → 60.3 - Feb 26
Whiteboard: [AS60MVP] → [strings needed][AS60MVP]
No longer blocks: 1401464
Depends on: 1401464
Iteration: 60.3 - Feb 26 → 60.4 - Mar 12
Iteration: 60.4 - Mar 12 → 61.1 - Mar 26
Strings landed for localization in https://github.com/mozilla/activity-stream-l10n/pull/11
Whiteboard: [strings needed][AS60MVP] → [strings landed][AS60MVP]
Whiteboard: [strings landed][AS60MVP] → [strings landed]
Priority: P1 → P3
Whiteboard: [strings landed] → [strings landed] [ThemeCust-MVP]
Priority: P3 → P2
Blocks: 1444980
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Blocks: 1448443
QA Whiteboard: [good first verify]
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.