Closed Bug 1403154 Opened 2 years ago Closed 2 years ago

Crash in mozilla::dom::PerformanceNavigationTiming::Type

Categories

(Core :: Networking, defect, P1, critical)

Unspecified
All
defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed

People

(Reporter: marcia, Assigned: valentin)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-bd05a140-6cbe-4b70-aec1-ecd500170926.
=============================================================

Seen while looking at nightly data: http://bit.ly/2fOxhgq. Crashes occur on Mac, Linux and Android.

Crashes started using 20170926100259 on Desktop.

Possible regression range based on crash stats: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5f3f19824efa14cc6db546baf59c54a0fc15ddc9&tochange=bc56729898954e32d3a3731d03d178ed78924c33

Bug 1263722 touched code on this area. ni on :valentin
Flags: needinfo?(valentin.gosu)
Assignee: nobody → valentin.gosu
Flags: needinfo?(valentin.gosu)
Priority: -- → P1
Nightly 58 x64 20170926100259 de_DE @ Debian Testing (KDE / Radeon RX480)
bp-ac6fda94-9b42-496b-b21e-eb08c0170926
OS: Mac OS X → All
The navigation type is initialized here:
http://searchfox.org/mozilla-central/rev/f6dc0e40b51a37c34e1683865395e72e7fca592c/docshell/base/nsDocShell.cpp#7465

The type is set to RESERVED in a number of situations.
http://searchfox.org/mozilla-central/rev/f6dc0e40b51a37c34e1683865395e72e7fca592c/docshell/base/nsDocShell.cpp#730-735

I'll remove the MOZ_CRASH for now, and file a follow-up to decide if we should change out behaviour there.
Blocks: 1263722
Comment on attachment 8912266 [details]
Bug 1403154 - Don't MOZ_CRASH in PerformanceNavigationTiming::Type if the navigation type is TYPE_RESERVED

https://reviewboard.mozilla.org/r/183616/#review188808

::: dom/performance/PerformanceNavigationTiming.cpp
(Diff revision 1)
>        break;
>      case nsDOMNavigationTiming::TYPE_BACK_FORWARD:
>        return NavigationType::Back_forward;
>        break;
>      default:
> -      MOZ_CRASH(); // Should not happen

Add a comment about the type here.
Attachment #8912266 - Flags: review?(amarchesini) → review+
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/68fc2ac8d51e
Don't MOZ_CRASH in PerformanceNavigationTiming::Type if the navigation type is TYPE_RESERVED r=baku
I have a specific recreation scenario if you are interested. It happens when you go to 

The settings for a Github project you own and then click on "Collaborators & teams"

Crashes every time.
Crash Signature: [@ mozilla::dom::PerformanceNavigationTiming::Type] → [@ mozilla::dom::PerformanceNavigationTiming::Type] [@ mozilla::dom::PerformanceNavigationTimingBinding::get_type]
Duplicate of this bug: 1403265
I had the same problem in Github. Just Google for some issue in Github, and click (will open in a new tab), then both tabs will crash.

https://crash-stats.mozilla.com/report/index/12151dc8-8fc7-4d70-9fb6-e0dd50170926
Duplicate of this bug: 1403280
Please can we expedite this to mozilla-central and do a respin? It's actively preventing me from working at the moment, since the vast majority of GitHub pages crash.
https://hg.mozilla.org/mozilla-central/rev/68fc2ac8d51e
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
You need to log in before you can comment on or make changes to this bug.